Blue screen of death in Win2k

vbimport

#1

I installed cloneCD fine (w/ reboot), tried to
burn a CD, and failed. So I uninstalled it
fine. Then, I got convinced to retry it. So I
reinstalled it. In the middle of the install,
the machine crapped out to a blue screen of
death (specifically, a STOP error). Since then,
cannot boot into my windows partition (in ANY
mode - safe, logging, directory services
restore). I am sending this email from Linux
partition.

System:
Windows 2000 Professional SP3
1.0 Ghz
768mb ram
40g WDD hdd
Plextor CDRW
Mary500 Atapi CDrom
Nvidia GeForce 32mb ram


#2

Part of the STOP error was off the screen , I couldn’t see it. Quite a huge find, I would say…

c00002bc {Unable to load device driver} \Systemroot\System32\Drivers\ElbyCDFL.sys device driver could not be loaded.

STOP

my question remains: how to remove this registry entry if I CANT FREAKIN GET INTO WINDOWS!


#3

I do not know how to get into registry without possibly the use of thrid party software or a bootdisk(try bootdisk.com) but I can suggest the following. Boot off winXP cd-rom. Start setup and when prompted to install windows chooose recovery console. Do the command: fixboot and fixmbr from dos like prompts. There is a very slim chance this will help or at least allow a safeboot or a roll back to last known good on your next attempt. Tahts the best I can do off hand to offer help.


#4

Originally posted by lilhoser
[B]Part of the STOP error was off the screen , I couldn’t see it. Quite a huge find, I would say…

c00002bc {Unable to load device driver} \Systemroot\System32\Drivers\ElbyCDFL.sys device driver could not be loaded.

STOP

my question remains: how to remove this registry entry if I CANT FREAKIN GET INTO WINDOWS! [/B]
CloneCD works fine in Win2K SP3 for me.

http://support.microsoft.com/default.aspx?scid=kb;en-us;101668

http://support.microsoft.com/default.aspx?scid=fh;en-us;win2000


#5

I will try these suggestions and reply later. Thanks for the help.

Note: For the record, CloneCD did work fine for me in win2k on the first install. I guess the uninstall didn’t remove some files, which confused windows on the next reboot. Maybe you should check the uninstall routine for bugs? Just a suggestion.


#6

I suspect CloneCD does not uninstall prefectly. This is because after I once uninstalled it and then reinstalled it, with a reboot in between. The registry kept my serial key. I had it registered to my name without entering the registartion with the reinstall. To test this I tried it again, and sure enough the key always stays. I guess this implies that CloneCD does not uninstall perfectly (whether this be intentional or not) and that there are remains in the registry.


#7

I think that the virtual drive causes many problems. I had one with XP Pro. Although I uninstalled it the drivers remained behind. Whether they are loaded or not on restart I don’t know.


#8

Well, folks, I have tried everything I can think of…I’ve tried dozens of bootdisks and registry scanning utilities (none of which can work in msdos mode, and neither redhat nor any previous version of windows boots can recognize NTFS partition), and i’ve even tried to delete these .sys files from my windows partition thru linux (cant mount it though, NTFS). i can’t edit the registry or delete these files! Does anyone have any ideas? Is there some wonderful utility that can run in msdos mode and give me access to the NTFS partition where I can scan the registry or delete a file? Any ideas how to mount an NTFS partition in Redhat 8.0? So far I can’t find any, and I’ve been looking all day. Please , any ideas. Thank you all…
Note: no amt of coffee, cigarettes, pot, et al has helped


#9

Use your Win2k CD and boot into the recovery console. Should end up at a dos-ish looking C:\ prompt, and try:

disable ElbyCDFL.sys

I don’t know if it has to be capitalized or not, or if it requires the full path or not, OR if the actual driver name is even the same as the filename (hopefully it is). According to Micro$oft that should disable that particular driver, hopefully to the point that 2k will boot up for you.

Check this long-winded url for a list of recovery console commands:

http://www.microsoft.com/technet/treeview/default.asp?url=/technet/prodtechnol/winxppro/proddocs/recovery_console_cmds.asp


#10

You can’t create a working NTFS boot disk with these instructions? Get access to another Win2K machine (surely you can do this?).

HOW TO: Create a Boot Disk for an NTFS or FAT Partition in Windows


#11

Hi -

I tried disable and other console recovery commands, and it couldnt find the driver entry to disable it.

I tried several boot disks, none allowed me to get at the files to delete it or the registry. I also tried the one you mentioned (futureproof) but it didnt work - until i researched a little more. What did work was to create an Emergency boot diskette and put custom commands in the setup.log file - then i downloaded and installed cloneCD on my win2k laptop and pulled the .sys driver from that installation and put it on the diskette with the setup.log. I put my win2k installation cd in the drive, booted from it, selected repair install, put the diskette in, and it replaced the driver and windows booted next time. for anyone in the future reading this post with the same problem, here are the msft kb articles:

http://support.microsoft.com/default.aspx?scid=kb;en-us;160495
http://support.microsoft.com/default.aspx?scid=kb;en-us;164471

BUT…

Now everytime I boot up I get “new device found” prompt and it attempts to install the “virtual clone drive” - regardless of disabling and removing the device. if i install it, blue screen of death right when it tries to installl…i’ve desperately tried to clean the registry, by removing any Key referring to “elby” - there are dozens and dozens and some were allowed to be removed, many weren’t. I’m going to dload a registry cleaner and try that. Unless anyone has better suggestions…my question is why the hell the registry entries are left - and apparently the files are too! What kind of uninstall is that???

Thanks again for ya’lls help!
Aaron


#12

Why don’t u just reinstallk win2k over the top of it.

When you boot, don’t go to repair, go to install.

It will detect the previous copy of win2k and ask if you want to repair it, or overwrite it, just repair it :slight_smile:

It will replace updated drivers with the Win2K default drivers :slight_smile:
And hopefully fix the IDE/ASPI dll which most likely is causing the issues.

It will be set back to original win2k, but you can apply the service pack later.

If it hangs, then use safe mode to boot :slight_smile:


#13

I had the same problem when I installed the Elby Virtual CD. Blue screen of death about 40 sec after starting windows, in any mode (normal, safe, etc). After many attempts trying to very quikly deactivating the device (or perhaps changing in the BIOS “Plug and Play Operating System” from yes to no) I could start windows, but the device remained there no matter how I tried to uninstall it (after trying to uninstall, the blue screen did not appear again unless I tried to access the SCSI drive).

At the end what I did is the following:
RENAME the files
c:\windows\system32\ElbyCDIO.dll
c:\windows\system32\ElbyVCD.dll
c:\windows\system32\drivers\ElbyCDFL.sys
c:\windows\system32\drivers\ElbyCDIO.sys
c:\windows\system32\drivers\ElbyVCD.sys

… but that would deactivate the normal CD-Rom as well… so rename only the VCD files. If you also have the 40sec every time you restart your system, you could try writing a .bat file in a diskette to rename the files and run it.
Any questions feel free to email me: cdavidm@hotmail.com