Blue screen after windows media player install

vbimport

#1

I’ve been updating my Sony VAIO GXR600 running win2k sp4 that I booted up for the first time this week since april of 2007. There were 80+ security/important windows updates and I didn’t try to download/install all at once. I’ve been doing about 10 at a time.

A lot of the updates listed were to windows media player or other media components. Before installing any media updates I uninstalled WMP 7.1 and installed WMP9 for win2k at the MS download site. I don’t know if WMP really gets any more secure w/ increasing version number, but it’s always in the lists of security recs.

I don’t remember if that install required a reboot. IF it did, then win2k booted ok after installing WMP, The problem happened on the reboot after using Windows Update and installing any media updates still listed. On the required reboot I got a blue screen w/ the message “Driver unloaded w/out canceling pending operations” that blamed cdr4_2k.sys.

I was able to boot the Sony into safe mode and I’m using my not-finished setting-up-after-OS-reinstall thinkpad to internet. Googling associates this error w/ WMP, Roxio drivers and DivX , I’ve never had Roxio installed on the Sony, but a search for cdr4_2k.sys on the hd yielded 2 - one installed w/ Genie Pro backup software.that’s in program files & is a Sonic driver. The cdr4_2k.sys in system32 is a Roxio driver.

I don’t know what DivX is, but I don’t think it’s on the Sony. Not under Add/Remove anyway.

Will uninstalling WMP help at this point? Should I uninstall the updates also?


#2

This is explanation for DivX

For latest version on WMP, you need latest version of DivX. That could be a reason you laptop is crashing.


#3

Thanks CDuncle,

A search for “DivX” on my hd found nothing so DivX isn’t installed. The Sony did come w/ video editing & dvd player software installed - dvgate, something called motion jpeg software decoder & intervideo windvd - maybe one of these also uses cdr4_2k.sys. But they aren’t loaded at startup and I haven’t installed/opened/used any since installing WMP 9 so I wouldn’t think any could be causing a blue screen.

The version of cdr4_2k.sys in system32\drivers on the Sony is 5.3.2.31, which appears to be the correct version for wmp9 per the only link I could find re the DRIVER_ULOADED_WITHOUT_CANCELLING_ PENDING_ OPERATIONS - cdr4_2k.sys error http://club.myce.com/f59/blue-screen-cdr4_2k-sys-roxio-245352/.

In its Startup tab WinPatrol has several dll files listed that were supposed to run once at the first startup after installing wmp9 and these dlls are still listed in the registry under HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunOnce. I think either I did not reboot after installing wmp9 before running windows update and installing wmp updates like I intended and thought I did and the updates are preventing wmp to complete its installation or I did reboot but the runonce dlls didn’t run or ran but didn’t clear from the registry for some reason.

I think I should uninstall the recent windows media updates, uninstall wmp9, clear the runonce dlls from the registry and try rebooting.

In the above link I understood the cause of the blue screen to be the replacement of the cdr4_2k.sys in system32\drivers installed by wmp being replaced by a later version when DivX Player 6.5 was installed. I couldn’t figure out exactly what Ascii2 was asking, but rptasiuk suggested reinstalling DirectX device drivers. Would this enable wmp to use a later version of cdr4_2k.sy? How do you install DirectX device drivers?

I’m not familiar w/ windows media/gaming components - don’t know what windows Media Format Runtime is or when DirectX is necessary. No minimum DirectX or other windows component versions were listed in the WMP 9 readme. DirectX 8.1 is installed on the Sony. I was planning on chking if the latest version of DirectX 9 was compatible w/ win2k after I finished installing all the security updates. Per rptasiuk it sounds like I should reinstall DirectX after installing wmp, whether I stay w/ 8.1 or upgrade to 9.

I’m wondering if I get wmp successfully installed if I’m likely to have a problem later with another program installing a later version of cdr4_2k.sys and if I can prevent that by installing DirectX device drivers after I install wmp.

Genie backup software has a Sonic version of cdr4_2k.sys that I guess loads from program files\genie. What would happen if I ran wmp & genie at the same time I don’t know.


#4

I would restore back to where it was before you installed all those updates and start installing them one by one.
I know it is lots of work, but two years of updates may get mixed up if you do not restart right when they ask for it.


#5

Thanks CDuncle for the quick reply,

I uninstalled the wmp updates, uninstalled wmp 9 [and got the message that windows was “rolling back” wmp to the earlier version], deleted the entries from runonce in the registry, rebooted and got the same error message.

I then tried booting into the LastKnownGoodConfiguration [that NEVER works for me] and got the same error message. So I booted back into safe mode.

After I deleted the entries in runonce, I took a look in run and noticed there was an entry for the Genie back up software. Neither msconfig nor winpatrol listed it and I didn’t recognize it in taskmanager processes list. This time when I booted back into safe mode I uninstalled genie. When I checked the run entries in the registry, genie had been removed. So I rebooted and this time windows loaded.

I’m thinking that the cdr4_2k.sys in system32\drivers prior to the wmp9 install must have been the Sonic version compatible w/ genie. Installing wmp9 overwrote the Sonic version with the roxio version in system32\drivers and since genie loaded at startup it objected. After uninstalling both wmp9 and genie there’s no cdr4_2k.sys in system32\drivers.

I probably could have deleted the genie registry run entry or put the cdr4_2k.sys from program files\genie in sytem32 and got windows to boot, altho I’m not sure what was the problem w/ those runonces that didn’t run once or didn’t run at all.

I think cdr4_2k.sys must be used by both genie & wmp9 for burning cds.
win2k is supposed to protect against new dlls being overwritten by older dlls, but neither win2k or winxp seem to handle anything to do w/ writing to optical drives well.


#6

Good it worked for you.
I run WinXP and had similar problem with Roxio Drivers. In my case it was fight between Nero and Roxio.