Blu Ray Playback always in French

vbimport

#1

I am using the latest version of Any DVD 6.5.0.7 and when I try to playback the Movie in PowerDVD 8 Ultra, it plays in French.

Went to any dvd language selection and put to english, then Removed Blu-Ray region code A. And when I play M2TS file from Stream folderon disc it automaticly plays in French. Anyone have a solution to this. Any suggestions will help.


#2

Yup. Don’t play the m2ts file. :slight_smile: PowerDVD won’t support the HD audio tracks when playing directly from the m2ts, so it picks the first non-HD audio track. In this case a nice French AC3 track. :slight_smile: If you’re trying to play backups you should create ISO files and mount them with Virtual CloneDrive. Then PowerDVD will treat it like a real disc and you can select your audio track correctly.


#3

Thanks for the fast reply, Just wondering how do I go about creating an ISO file for me to run. I’m used to the one click backups from DVD’s not Blu-ray’s. And I just downloaded Virtual Clone Drive.

Also The M2TS file works for Casino Royal, is that because it doesn’t have the HD audio capability?


#4

So, use AnyDVD, right click on the fox icon and select “Rip to image…” to create an ISO image. Then just mount it in Virtual CloneDrive. One word of caution. Disable AnyDVD for the virtual drive. You can do that in the settings. AnyDVD will remove the protection from your images and having AnyDVD enabled on the unprotected image can sometimes cause issues. Disabling AnyDVD for the virtual drive is easy and will keep you from going nuts. :slight_smile:

Casino Royal may have a non-HD audio english track as the first non-HD audio track. Very possible. I don’t feel like checking mine right now.