Blu ray does not communicate thru sata port

vbimport

#1

I have an asus m2n68 mobo with 4gb ram 2.5 ghz cpu and 550 w power, and 64 bit.

i have an lg ggc h20l internal blu ray player connected to the mobo, but it is non responsive when connected with sata, it will only work connected to an ide port.

i have been on various forums , but my problem still happens.

i was told to use vlc with the blu ray drive connected to sata port but still no success.

any help would be greatly appreciated.

:confused::confused::frowning:


#2

The GGC H20L is a SATA drive. I must assume you are using a SATA->IDE adapter to connect to an IDE port.

Does the drive show up in the bios of the motherboard when connected to a SATA port? Does it show up in Device Manager (assuming you are using Windows)? Does it show a yellow ! next to the drive in Device Manager?

When you load a blu ray movie into the drive, does the name of the movie show up on the drive icon in My Computer?

If all of these are fine, you should try the trial of Arcsoft TotalMedia Theater to see if it will play Blu Ray movies while the drive is hooked up to a SATA port.


#3

the drive shows up in device manager all fine.

as for the software, i have tried cyberlink, total theatre, vlc, and none work.

As i said when the drive is connected with the sata to ide converter (connected to IDE port) the drive will work as it should when connected to sata. but when i connect the drive to the sata port windows says"installing new hardware" “device ready to use” so it detects it ok, but is non responsive after that.
the software can not open the communication to the drive.

i have tried every piece of software , but it has not fixed the problem.

i have no idea how to solve this problem??/

i appreciate all advice and info.
keep it coming


#4

I think I might try updating the chipset drivers, which should include drivers for the SATA controller on the motherboard. Look under downloads here at the Asus site: http://www.asus.com/Product.aspx?P_ID=TtvnYkYtXtRgFXG3

By the way, are you having any other problems with SATA devices on this computer? Or is it only with this one LG drive?

You’ve probably tried plugging it into different SATA ports, but it is an obvious thing to try that you haven’t mentioned.


#5

I think i have solved this problem.
when i bought the drive it came with a sata cable and a molex to sata power cable, now i didnt bother using this little cable as the computers power had a sata power cable from it, so it was working but when a program tried to communicate with it ,it wouldnt do anything, so i found this molex-sata power cable and tried it out with the same program and it worked.

I had assumed the the molex-sata power cable was not needed as the PSU already had a sata connector coming from it, but after trying it out, it seemed to start responding. :slight_smile: