BlockBuster DVD is not recognized in LG GSA-4120B

vbimport

#1

Hi, I rent a DVD movie “Troy” from BlockBuster and try to play it in my computer. The drive doesn’t even recognize the DVD. It keep trying to read and then stops. Nothing shows up in Windows Explorer. Does anybody is having the same problem? I am using the original firmware A104.

Any help would be appreciated.

Thanks,

Mike


#2
  1. you might be on the wrong region

  2. try ripping with DECRYPTER

  3. the disc might be bad

Many movies have passed through my 4120B. no problems at all.


#3

Hmm… Regional Code is 1, and I live in North America…

DVD plays OK on another DVD player.

And the problem is my writer never recognize the DVD…

Can anybody tell me if the regional codes are different, can the writer still
recognize the DVD? And it just doesn’t play the movie right?

Mike


#4

Can the same GSA-4120B read recordable DVD disks and other DVD-Video disks?


#5

go to my computer/properties/hardware/device manager/DVD-D drives/4120/properties/dvd-region

and see that its marked region 1.

also, if you load dvd decrypter and the drive can recognize the disc, then decrypter will load its content. then you’ll know if the drive recognizes the disc.


#6

To Kenshin:
Yes, so far I can read the DVDs I burn, I can read a DVD that has no regional code in it. (I will have to check if it is a DVD-Video)

To Igy:
The regional code is 1.
I will try the dvd decrypter.

Thanks all, I really want to try it out before tomorrow noon before I return the DVD.
Or else I will have to rent another one to try it out.

Mike


#7

DVD rent is too expensive where I live. US$2 per title. :sad:


#8

where i live it’s 3$. however, due to the quantities i rent i get it for 1$ a piece. I wish that verbatim would grant me with the same 1:3 qty discount :sad:


#9

OK, renting more is fine, just would like to try knowing the problem asap,
if possible.

A side question. Even if the regional codes do not match, the writer should
still see the folder structures in Windows Explorer right?

Mike


#10

Hm. Though I have had quite many DVD writers and media, I never had many DVD-Video titles and never was interested in regional codes. :bigsmile: (I’ve thought of DVD as successor to CD for storing encyclopedia and books rather than movies.)

Why don’t you first update your firmware to A115 RPC-1?

http://tdb.rpc1.org/#GSA4120B


#11

Sounds like a good firmware.

I checked Canada’s LG’s webpage about firmware A111, it states:

This firmware update is for drives with original firmware versions below A104.
The drives must be original LG branded drives with the DVD Writer
model number GSA-4120B(no OEM units).

I am confused with this warning. I am with the A104 as original firmware.
Is going to A115 possible? I think so but can anybody verify?

Mike


#12

Please disregard the warning. It is extremely rare and unlikely to have a failed drive from running a firmware flasher to write firmware.

You can go directly from A104 to A115 which is available on the linked page above.


#13

been flashed to A115, haven’t really try the other features of this firmware. However, it still won’t play the DVD. I went back to Blockbuster to exchange another one while renting another movie. It can load the other movie no problem, but same problem happened to “Troy”. I guess it’s that specific DVD’s problem.

Heard anything about protection in “Troy”, or that LG GSA-4120 is specially
picky with some DVDs?

I think the problem has been solved. Thanks for all your help. I really appreciated it.

Thanks,

Mike

P.S. Another thing I noticed is that a software HOTLLAMA prompted for installation when I insert the other movie. Apparently there is a LAUNCH.BAT in the DVD. Anybody has this experience?


#14

No idea.

Perhaps the unreadable discs have some scratches. Standalones usually don’t mind scratches, just skipping unreadable sectors.


#15

have you tried DVD DECRYPTER?


#16

On the other movie, DVD decrypter can see the files. With “Troy”, there isn’t any response from both the drive or decrypter. The drive couldn’t even recognize the disc, there should be no way decrypter can see it.

Anyways, Thanks.


#17

Hello,

Yesterday i had the same problem as mikemikey did. The dvd was the film “Terminal”. The drive (LG4120 firmware A115 autoreset and rpc1 - i tried both) doesn’t recognise the dvd. If i turn on dvddecryptor before i insert the dvd, the software stops responding. I have also a NEC 1300A in my system and it recognised the dvd with or without dvddecryptor.

Is it a new proteccion system?


#18

I wish I had those titles. I have both LG drives and ND-1300A.


#19

Some titles have protection that prevent the disk from being read by DVD-ROM(or DVD-RW). ‘‘Troy’’ is probably one of them.

Maybe you will find some answers in the DVD Movie Backup Forum.