Blindwrite image works from one location but not another

vbimport

#1

I have created an image using blindwrite of “Toca Racing Driver 2” or “V8 Supercars 2” as its known here in Australia. The image was written to a laptop that is networked to my desktop. When i mount this image with daemon tools from the laptop (through the network) it works fine, however if i copy the image files over to my desktop system and mount them it doesn’t. Well it does actually mount correctly however when i run the game i get a disc identification error. I can’t think why it would work from one location and not another, unless there is some info about the original location stored in the .B5T file. Does anyone have any idea’s. This game has been a bit of prick as it uses starforce3.


#2

If you do a search you will find that there is a bug in Starforce 3 that allows it to be run over a network, but not on just one computer.


#3

Is there anyway around this or do starforce3 images always have to be mounted through a network?


#4

At present, there is onyl 2 known ways to mount a StarForce 3 protected image :

  1. Disconnect ALL physical IDE Optical Devices (Drives) From your computer and run it, but I think that has been killed in the newer versions.

  2. Do it over a network.


#5

You can read up about it here.


#6

i have disconnected my ide dvd drive and can still only get the game to work when the image is mounted through the network.

Actually reading the link from above it seems this actually the only way to get the game to run. What a pain in the ass

thatks for your help $CyBeRwIz$


#7

I know, it is a pain in the A$$, but I hear the BlindWrite team are working on a solution:)

No problem.


#8

Does anyone knows why the image works when mounted over a network ?

I was thinking it was because of the “lag” the network introduces : hard drives seeks are extremely fast, so when an app sends a read command to the virtual drive, it gets an answer almost immediately, and SF (and maybe Securom 5 ?) probably uses this in its newer versions to detect virtual drives. When the image is mounted over a network, it takes more time, so the virtual CD behaves more like a normal CD and SF is fooled.


#9

Not a bad explanation, sounds good too me! I just hope that it gets solved soon by the bw team though!


#10

Yes, that is a quite logical explanation. Another is that with the disconnect IDE Drives trick, maybe that because it is running from a different loacation, the check is not built in to check those other places.


#11

I slight disagree, because sometimes cd authentication stops if the cd takes to long to authenticate.

Slam me if im wrong… :smiley:


#12

It does, sometimes, but if it can’t authenticate, the game usually won’t run.


#13

Anyway, i just tested this method on Securom 5.xx with the games Chrome (1.3 patch) and Deus Ex 2 (1.2 patch) using Alcohol’s virtual drive : it just works !!! When mounted locally, i get the “emulation software detected visit securom.com/emulation blah blah” message, but when mounted over a network, it authenticates after about 10 sec.