Bitsetting for DVD+R is here!

Enjoy! Thanks to anarki for hosting it!

This is a beta version, so be careful.

http://digilander.libero.it/pmforum/49b1_2.zip

works with 0048 FW?

Marco is not missing!!!
He (and his team) have been working hard!!!

He sent me by email this beta version last Friday.
The only thing I can tell you is that IT WORKS! :slight_smile:
The disks burned with this firmware can now be played on my old DVD player. This player could only (until now) play true DVD-VIDEO disks. It now can play DVD+R with no problem (with the DVD-ROM bitsetting). (This player continues to not play DVD-R,DVD-RW and DVD+RW disks)

DVDinfopro reports same strange bitsetting when tested on the BTC drive.
Please, use a different DVD-ROM when checking the DVD bitsetting.

Conclusion:
Excelent job BTC team.:bow:
I’m very happy with this version. Bitsetting for DVD+R (and DVD+RW) seams to work well. My DVD players can now play DVD+R disks.

:bow: :bow: :bow: :bow: :bow: :bow: :bow: :bow: :bow:

:bigsmile: great! but i suppose its for the 1004 not for the 1008 drive, can somebody confirm this? i don’t want to ruin my 1008 when using a wrong flash update…

if it is a 1004 beta firmware i sure hope there will be a 1008 version soon…

:wink:

This beta version is for 1004

can anyone please make a copy of the firmware after flashing this and upload it.
I can’t get this one to flash, i’ve tried everything I can think of. So i’d like to try a single bin file if possible.

Ta

fards

How do I use this tool? After the disc is burnt or before?

Insert the blank disk
Set the disk to DVD-ROM (with the BTC utility)
Start Nero and burn the DVD-VIDEO.

Hi guys,

First post, I,ve burnt a few coasters. Still haven’t got a DVD -R to work on stand alone. Work on PC tho.

My problem is:

When I try to run bitseter it gives the following error:

             The PSAPI.DLL file is
             linked to missing export NTDL.DLL:_stricmp

Any one have any idea why?:confused:

I don’t know if anyone else feels this way, but why can’t they just do it this way:

Write a firmware and a utility that allows the user to set the default behavior when writing + media. When the user runs the utility, he sets the default booktype of +R media to, say, DVD-ROM and +RW to dvd-RW. The drive should keep this untils its changed again using the utility(or even until you reboot your PC). Having to run the utility on each disk is just a pain.

Some + only drives just default to always writing the booktype to DVD-ROM and I don’t see anyone having problems with that either.

What do ya’ll think?

Hi worraps,

On a WinXP SP1 system:

C:\WINDOWS\SYSTEM32\PSAPI.DLL - Process Status Helper;

C:\WINDOWS\SYSTEM32\NTDLL.DLL - NT Layer DLL.

In layman’s terms, one (maybe two) file(s) which the utility depends on is/are missing.

Win9x has its own version of NTDLL.DLL known as ‘Win32 NTDLL core component’, but does not have a PSAPI.DLL by default.

Even if these two files are present, the utility may still not work properly because they require an NT system ie WinNT4/2K/XP.

Hi Quaxx

I’m running 98SE

I have the following files

C:\WINDOWS\SYSTEM\PSAPI.DLL - Process Status Helper;

C:\WINDOWS\SYSTEM\NTDLL.DLL - NT Layer DLL.

I don’t think the bitsetter works only in XP/NT (correct me if i’m wrong).

I don’t think removing them would solve the problem, as I have PSAPI.DLL in a Norton folder and a WinHex folder.

You quick reply and help greatly appreciated.

I exchaned the PSAPI.DLL in C:\WINDOW\SYSTEM with the one from the Norton directory, and got the following error:

The PSAPI.DLL file is
linked to missing export NTDLL.DLL:NtAllocateVirtualMemory.

The original error was

The PSAPI.DLL file is
linked to missing export NTDLL.DLL:_stricmp.

NT files on my 98SE! Why are they there? Does bitsetter only work with NT?

Everything else seems to work OK.

Looks like i’ll have to give bitsetter a miss, and try to find DVD media that will work in my Cyber Home AD-L528.

if this will help my situation… I recently flashed to version 048 and now (at least) my burned dvd will play in my RCA DRC8000 DVD Recorder, however, the video/sound breakup heavily on my Panasonic RP-56. I’m using Verbatim (CMC MAG R01) +R blanks.

Additionally after the upgrade to 48, my stand alone will play burned DVD+RW (the RIDATA original) where it previously woulnd’t recognize the disk.

My question is how do I use the previously supplied .hex files for the 049 Beta version? I’d like to give this method a try!

Thanks!

i used the firmware with the command line:

mtkflash 1 w /c /m16 /h all.hex

it ran slowly from 1 - 100% (only 1 time)
after that, my writer wasn’t able to read DVD no more.

what did i do wrong?

(using the latest mtkflash)

i used the firmware with the command line:

mtkflash 1 w /c /m16 /h all.hex

it ran slowly from 1 - 100% (only 1 time)
after that, my writer wasn’t able to read DVD no more.

You need to run the command 16 times, 1 for each bank:

mtkflash 1 w /A0 all0.hex
mtkflash 1 w /A1 all1.hex
mtkflash 1 w /A2 all2.hex
mtkflash 1 w /A3 all3.hex
mtkflash 1 w /A4 all4.hex
mtkflash 1 w /A5 all5.hex
mtkflash 1 w /A6 all6.hex
mtkflash 1 w /A7 all7.hex
mtkflash 1 w /A8 all8.hex
mtkflash 1 w /A9 all9.hex
mtkflash 1 w /A10 allA.hex
mtkflash 1 w /A11 allB.hex
mtkflash 1 w /A12 allC.hex
mtkflash 1 w /A13 allD.hex
mtkflash 1 w /A14 allE.hex
mtkflash 1 w /A15 allF.hex

When you used all.hex and it did not exist, you probably cleared the eeprom and then did not write anything back to it.

Originally posted by schapeke
[B]i used the firmware with the command line:

mtkflash 1 w /c /m16 /h all.hex

[/B]

Hi schapeke,

your comand for flashing the drive was not ok! How is your DVD-writer connected to the Motherboard?

IDE 1 master: you use “1”
IDE 1 slave: you use “2”
IDE 2 master: you use “3”
IDE 2 slave: you use “4”

As you wrote it in your post it would be on the IDE 1 connected as master, and there should be your harddisk!

Greetings Klausi

Originally posted by ccbadd
You need to run the command 16 times, 1 for each bank:

mtkflash 1 w /A0 all0.hex
mtkflash 1 w /A1 all1.hex
etc.

I’m not so sure that this is a must. There’s more than one way to skin a cat.

This is the batch command line in the DOS package Marco sends out by request:

mtkflash 3 w /c /m16 all.hex

and I haven’t heard any complaints about it.

Note that Marco included a MTKFLASH version which defaults to hex, so the /h switch is not set in his command line.

@schapeke: a) Which MTKFLASH version did you use when your flash went bad?

b) I rather tend to think that Klausi has a point in his post where he mentioned that your command would flash the primary master. Is your OD really connected as a master on your primary IDE channel?

Regards, Martin A

Edit: @schapeke: I forgot to ask whether the all.hex file in your command line was one file or actually 16 (bank-sized) files according to the pattern given by ccbadd.

Hi.

Can I use the MtkWinFlash to flash the 0049 beta on the Drive?

Must have a single file binary

  • if i do the flashingsteps for every of the HEX files? Do this works?

i used the latest version of mtkflash (1.80.1) that has the bin as standard. so i have to use the /h option.

my 1004 is connected to the primary master. so 1 was also correct. (hard disk is on SATA)

maybe i have to try an older version of mtkflash?

luckily, i was able to flash it back to 48 firmware :slight_smile:

to make life easy, can someone who already flashed his drive with 49, put a bin file online?

thank you

PS: for creating the bin file, use “mtkflash # r /b /m filename.bin”

as you can see here:
mtkflash page