Bios wont recognize ide cd drives

Hi there. I did some googling and I found a somewhat similar problem here that was easily resolved so I decided to register. I have a dell xps 600 that I purchased a couple years ago and it’s been working fine. But recently it’s been giving me
"

Phoenix ROM BIOS PLUS Version 1.10 A06
Copyright 1980-1988 Phoenix Technologies Ltd.
Copyright 1990-2005 Dell Inc.
All Rights Reserved

Dell System Dell DXG051
Bios version A06
www.dell.com

 Drive 4 not found: Parallel ATA, PATA-0 (IDE1 MASTER)
 Drive 5 not found: Parallel ATA, PATA-1 (IDE1 SLAVE)

"

This didn’t really bother me until today when I found out I couldn’t boot from either of my cd drives to fix windows. A few weeks ago I somehow got it to recognize one of my cd drives to install linux, but it seems that it’s back to being broken. Both my cd drives have full functionality in Windows Xp and in Ubuntu. I’ve tried playing with the master and slave configuration; I’ve put one on slave and the other master and switched the two multiple times. I have also tried cable select and configuring and then reseting the bios to factory default.

I have a Sony CD-R/RW Model: CRX217E-DR
and a Sony DVD-ROM Model: DDU1615-DR

This has caused me much frustration and I’m not even sure if this is the right forum to post this in. If you can shed some light on my problem that would be great. Thanks in advance.

-Matt

Hi and Welcome!

you might try if a new IDE cable (80wired, 18" (46cm) flat ribbon) solves the problem. Also check if all cables are seated properly and are not damaged.

Michael