BIOS doesn't recognise DVD RW drive

vbimport

#1

Good day,
a common problem that I cannot sort.
I have a Liteon SSM-8515S drive in my Fujitsi Siemens Amilo Pi 1505.

The common problem of drive disappearing in windows 7 has been around for a while on my laptop but now the drive isn’t even recognised in BIOS either!! This is becoming very frustrating.

I have tried every fix I can find - filters etc reflashed the BIOS to older versions with no joy either.

The DVD drive works fine in a USB enclosure. It also tries to work in the laptop (it opens the drive and spins a disc up with the drive light coming on) but nothing is detected anymore.

The drive has the GSO9 firmware? If I remember correctly.

Any new ideas will be gratefully received.

Heres hoping.

Cheers


#2

Hi,

have you already tried to reseat the drive?
I suspect, there is something wrong with the connector from the motherboard to the drive. Unfortunately, I have not any idea how to fix this apart from contacting Fujitsu (provided the laptop is still covered by warranty).

Michael


#3

Got it sorted somehow - this has been irritating me for four months now.
In my frustration i went into system devices and uninstalled the following

system management bios driver

intel 8202 firmware hub device

plug and play software device enumerator

and possibly ACPI embedded controller

rebooted with the drive firmly in place and voila. Four months of trying everything on the web I could find.

Coincidence?? maybe. I don’t care its up and running again.

Thanks for your reply though, I was thinking along those lines. Luckily its not the case

Cheers