Big Troubles to flash 48246s firmware

Hi all!
Please help me if you can, I bought liteon 48246s cd-rw last week and i tried to flash firmare with the new one ss09.exe downloaded from the liteonit site but it didn’t work.
My surprise is that my firmware revision is SID1 (looked with nero Infotool) and i really don’t know what version really is.:frowning:

I tried also with mtkflash 1.55 and ss09.bin but it hang up and remains to 00%, i restarted and tried several times, the recorder continues to work, but i cannot upgrade it in any way…
If u know what is the real problem please answer me!
Thanx…

What command are you using with mtkflash?

mtkflash 2 w /b ss09.bin. I suppose it may work the liteon is on primary slave…and i booted from a floppy.
But the real question is about the version of my cdrw SID1. I haven’t found anyone whit this revision of firmware.:confused:

:smiley:
I had the same problem!
I bought the burner today and I have also the same firmware SID1!

  • I used mtkflash 1.48 an SS09.BIN!
    Everything is OK!
    Now i habe SS09 Firmware!
    Perhaps you should take V. 1.48 of mtkflash!
    Knows someone, what firmware SID1 is?
    On the Homepage from Lite-On nothing is to be seen to upgrade from this firmware!
    Bye Bye and good luck!

ok, now i’m going to try…hope…and thanx

JohnMCLane,

My similar flash went OK. I have no idea why your flash failed, and am thus reporting everything that might be relevant.

I had no problem flashing a new Buslink 4848 (a native 48246S) from VS06 to VS09 using the Lite-on site SS09.EXE under XP PRO (no SP). FW was downloaded as of 6-December. SS09.EXE is dated 27-November-02, 07:27:22, size (unzipped) is 1,140,736. Do you match?

Reports as VS09, as expected.

Not that it’s likely to matter, but the drive is primary master - my HDDs are on a separate controller.

I saw no improvement in burning cheap media going from VS06 to VS09, but I’ll post that in greater detail in another thread- I have one unit that performs like all the others reported here, and one that does significantly better than normal with cheap media under VS04!

Good luck on your restoral.

Ok, thanx to all and especially to Akolpir, I finally updated my 48246s from SID1 to SS09 using mtkflash 1.48 and ss09.bin.
Goodbye and good luck to everyone…
P.S. : I don’t really know what SID1 version of firmware is. If anyone of you know please explain me, I would be really interested.
Bye Bye :smiley:

Fine! Nice that i could help you!
I have an idea! I believe Lite-On wants to annoy us!
I believe this problem only with oem burners arise!
The people from Lite-On do not want that we can make a firmware update with our OEM burners!
That´s the reason why we can´t find a update !
But those did not make the calculation with us!! Hä Hä!

It really could be possible.
But I hope we will always find some method to bypass any problem.
Greetings to you
Bye
:bigsmile: