Big Problem with new 1.04 firmware for 24X USB2

vbimport

#1

I went to the Japanese website and D/L'ed the 1.04 firmware upgrade for the USB2 Plextor 24x. It upgraded fine and then my computer would not recognize my drive when I re-booted. I figured I would take a shot and re-install the drivers and it worked. I can't figure out why the firmware upgrade corrupted my drivers somehow and made me re-install them in order to see my drive but it did.

Well, now I have 1.04 firmware but I still can't copy SD2.51 with my drive no matter what.:confused:


#2

Originally posted by KenL
[B]I went to the Japanese website and D/L’ed the 1.04 firmware upgrade for the USB2 Plextor 24x. It upgraded fine and then my computer would not recognize my drive when I re-booted. I figured I would take a shot and re-install the drivers and it worked. I can’t figure out why the firmware upgrade corrupted my drivers somehow and made me re-install them in order to see my drive but it did.

Well, now I have 1.04 firmware but I still can’t copy SD2.51 with my drive no matter what.:confused: [/B]

I guess you should only flash/use the fw of, where the drive is manufactured… and not otherwise…


#3

Originally posted by Fugitive
[B]

I guess you should only flash/use the fw of, where the drive is manufactured… and not otherwise… [/B]

BTW this “behaviour” (new hardware detection after fw upgrade) is also typical Windows XP behaviour… but in normal conditions it shouldn’t matter, maybe te japanese version has “intentional” copyright restrictions…
If possible you should use European fw’s but only when other people post positive results, you shouldn’t take any risks with fw’s…


#4

Never again but I was able to fix it this time so I was lucky.


#5

Originally posted by KenL
Never again but I was able to fix it this time so I was lucky.

Yes i know it’s tempting, most of the time the Japanese site is the first one to have new fw’s available, but i guess it pays of to be patient…

Fug.