BIG problem with ND-2510A

vbimport

#1

I cannot burn the drive with DMA enabled. I have to go to Windows Device Manager and turn off DMA on the IDE channel that my 2510A is on and use PIO. When I try to burn with DMA, I get a BSOD :a which says something about a “physical memory dump”. When I use PIO, the burn completes and the DVD is readable, but it takes 40 minutes :a

What should I do?


#2

What software and version are you using to burn?

Have you checked the following?
Version of your IDE drivers?
Tried swapping the IDE cable with a good quality one?
Tried different burning software?


#3

Someone here told me to uninstall the Bus IDE drivers and reinstall them. I did that, it doesn’t work. I don’t have any other IDE cables, and the same happens with all burning software.


#4

Its really worth trying a new cable :wink:
Also, do you get a BSOD on any other applications?


#5

Nope. I have Windows XP. I don’t get it on any other application.


#6

I also have an NEC 2510A and with DMA on get the BSOD with any DVD burns and some others. As above when I turn off DMA it takes ages and slows down my PC but works okay. The error is IRQL_NOT_LESS_OR_EQUAL. If I disconnet all my USB devices I still get a BSOD but instead it is a BAD_POOL error instead. I have XP SP2 and have already tried a complete re-install.