Betablocker Wont Work! On Xp

I am running winxp and when I try to execute the BetaBlocker no matter what version 1.0 english, french, italian, the one for safeDic@ 2.51 all I get is “Wrong Version of Run-time dll”.

Why?

Thanks

try running it has a win98 prog!!!

Version 1.01 runs ok here, try re-downloading the latest version and see what happens.