BenQ1625-Nero6 Problem

vbimport

#1

I just started using my new BenQ 1625 Lightscribe. I tried to use the Lightscribe function with Nero 6. I have the latest Nero Software and BenQ firmware. When I tried to use the Lightscribe function Nero gave a message saying that I needed to upgrade my firmware and then it directed me to a site that said that I didn’t have permission to access the site. Any ideas? This is my first attempt to use a Lightscribe burner.


#2

Go to the benq site, download the firmware BBGA and flash it. Then make sure you installed the software from surething.com (I think) to allow the lightscribe “dirver” to work.


#3

Hi, I own a BenQ 162I (16X+R16X-R) which I purchased a couple of months ago.
Have been really pleased with it especially the Book Management feature which is the only program that I use that was in the original package and the rest is Nero.

I thought that I would mention that the support a BenQ
was very good and sent me the exe. firmware check program which I use to check if I have forgotten which firmware it is that I have.
The check device is a handy command to have as time goes by, it was the support tech Ismail that emailed the Link to me.

He then said to always go to the Global site to check for firmware updates which is what I always do now, he said that the other sites are not kept as uptodate more often than not as is the Global site.

Just thought that I would add my experiences with BenQ support and how they have helped me.
Their number as you probably already know is 1-866-600-2367

Cheers and I hope things go better for you!!!