BenQ ZB37 from China or DW1800.ZB37.patched-fb.rar From Forum?

I just bought a new BenQ DW1800 DVD Burner with ZB35 Firmware…

I have been searching Benq Oficial WebPages for new firmwares without success…Only in BenQ-Malaysia I found the Version:

  • ZB35 (ZB35.zip - 962 KB) Dated 01-02-2007:

http://www.benq.com.my/support/downloads/drivercounter.cfm?dpid=2441&id=6113&size=962%20KB&type=B&filename=ZB35.zip&type=B&whereto=ftp%3A%2F%2F211.78.86.210%2Fdvd%2drw%2ffirmware%2fdw%5f1800%2fdw1800%2fzb35%2ezip

However in the following web address in China I found the Version ZB37?:

http://mydown.xinhuanet.com/driver/243/243407.html

http://mydown.xinhuanet.com/driver/243/243407_ds.html

http://redirect.mydown.com/mydown/predownhz.jsp?id=243407&p=0&j=0&m=1&url=http://mdl8.mydown.com/driver/200706/benq_DW1800_Firmware_ZB37.zip

I also search the forum and found others FastBurn Firmware for the Benq DW1800:

http://codeguys.rpc1.org/firmwares/dvdrw/DW1800.ZB34.patched-fb.rar
http://codeguys.rpc1.org/firmwares/dvdrw/DW1800.ZB35.patched-fb.rar
http://codeguys.rpc1.org/firmwares/dvdrw/DW1800.ZB37.patched-fb.rar


I would like to upgrade my BenQ DW1800 to the Latest/Best Firmware,
but I really dont know witch one is better… The ZB37 from China or the
DW1800.ZB37.patched-fb.rar from our forum??

Why there is only Version ZB35 in BenQ-Malaysia…Is the Version ZB37 Oficial?

What benefit will I get if my Drive is flashed with the FastBurn Firmware DW1800.ZB37.patched-fb.rar?

Thanks for help!

ZB37 is the latest official firmware, listed in BenQ China website:
http://service.benq.com.cn/DriverDown/DriverDown.aspx?ProductTypeID=52&ProductID=619

http://service.benq.com.cn/UploadFile/Drivers/ZIP/DW1800_Firmware_ZB37.zip

ZB37 fixed the bug which launching Nero would disable all QSuite settings.

BenQ-Malaysia haven’t updated their website yet :rolleyes:

With FastBurn firmware, you get shorter burning time at 12X or 8X.
12X: ~6:15 mins for a full burn
8X: ~8:10 mins for a full burn

Normally (stocked firmware):
12X: ~7.10 mins for a full burn
8X: ~8.15 mins for a full burn

So you will save about 1 min @12X with FastBurn firmware :wink:

Thanks Skylon for your fast reply!!

So the only differences between ZB37 from China and the
DW1800.ZB37.patched-fb.rar (from our forum) is that I will get
shorter burning time at 12X or 8X?..Any Other Changes?

I also have noted that the current version of QSuite is very Old, is there any
newsest version of this excelent utility for BenQ drives?

One Last question…I have been locking for a Complete review of the Benq DW1800 without success, anyone knows the link if available?

I am aware that the chipset in the DW1800 is not from Philips (Olds Benq Drives), but is this drive as excelent as others BenQs 1640-1655?

Thanks again for all your help!

  1. Yes, the C0deKing’s FastBurn firmware only speed up 8X and 12X burn, no other things were changed

  2. Latest QSuite is v2.1, no newer version yet

  3. DW1800 is a rebadged Lite-ON LH-18A1P, you can read the 18A1P Preview here:
    http://www.cdfreaks.com/reviews/Lite-On-LH-18A1P-DVD-Writer-Preview
    Or Review:
    http://cdrinfo.com/Sections/Reviews/Specific.aspx?ArticleId=18774

  4. The drive use MediaTek’s MTK1898 chipset, check out the scans:
    http://club.cdfreaks.com/showthread.php?t=198162

Posted by Skylon
2. Latest QSuite is v2.1, no newer version yet

In my opinion with BenQ no longer making ODDs, there will be no more QSuite updates. Just my opinion. :slight_smile:

Thanks Skylon and alan1476 !!!

Then I think that it is better to use the FastBurn DW1800.ZB37.patched-fb.rar
than the Oficial ZB37 Firmware (From BenQ China), to Flash-Update the DW1800?

Thanks also for the Lite-ON LH-18A1P reviews!..

Apparently the Lite-On LH-18A1P is overall a very good burner that if it is
Crossflashed to Benq 1800 firmware gives better burns!

Thanks again for all your help!!

Just To let you know that I Flash my drive to the latest
FastBurn Firmware DW1800.ZB37.patched-fb.rar without problems…

However after flashing the drive to ZB37, the Qsuite2.1 in Solid-Burn/EEPROM Clean Tool Display the following info:

Learned Disc: 0

Media Information:

1 ÿÿÿÿÿÿÿÿÿÿÿÿ

2 ÿÿÿÿÿÿÿÿÿÿÿÿ

3 ÿÿÿÿÿÿÿÿÿÿÿÿ

4 ÿÿÿÿÿÿÿÿÿÿÿÿ

5 ÿÿÿÿÿÿÿÿÿÿÿÿ

6 None (Clean)

Is this Normal…Or Is there any way to Fix this Problem?

I also would like to make my BenQ DW1800 Region Free…Any Suggestion?

Thanks for all your help

That’s normal :wink: . QSuite is not originally designed for BenQ drives with MediaTek chip.

About RPC1, you could try with LtnRPC. Also part of LtnFlash IIRC. :slight_smile:

Get EEPROM Utility from http://codeguys.rpc1.org/utilities.html and use the “Reset Learnt Media” or “Reset HyperTuning” to clear that weird information.

As pinto2 suggested, get LtnRPC from http://dhc014.rpc1.org/LtnRPC/ and disable the drive’s RPC, then it will be region free :wink:

Thanks pinto2 and Skylon for the info!

As you have suggested, I use EEPROM Utility and “Reset Learnt Media” and “Reset HyperTuning”, but the ¨ÿÿÿÿÿÿÿÿÿÿÿÿ¨weird information still there…The only
differences is that now QSuite2.1/Learned Disc: display ¨6¨ instead of 0…

Any Suggestions?..Do you think that I will have to Re-Flash Again to
the same FastBurn Firmware or to the Oficial ZB37 Firmware
(From BenQ China), to reset the ¨ÿÿÿÿÿÿÿÿÿÿÿÿ¨weird information?

1000Thanks!!

Sorry Skylon but I’ve to disagree because no “tool” in world will be able to clear out those “yyyyyyyy” displayed by QSuite… :wink:
Check out this post by C0deKing, among many others.

So apparently no tool in world will be able to clear out those “yyyyyyyy” displayed by QSuite…May “Reset Learnt Media” and “Reset HyperTuning” only works in Original BenQ Drives and not in the Newest Lite-ON ones?

If Qsuite2.1 in Solid-Burn/EEPROM Clean Tool Display the ÿÿÿÿÿÿÿÿÿÿÿÿ weird information, will the drive will learn the Media?

My New BenQ DW1800 Have ´Solid-Burn¨ in the Front Plate…

I had these “yyyyyyy” too sometime ago. I get the EEPROM Utility, and use “Reset Learnt Media” or “Reset HyperTuning”, only 1 of them will clear those information so you have to try. Then in QSuite, everything is blank in QSuite (no weird info). However, it’s showing ‘6 learned disc’. So I use the QSuite “Clean” button to reset the counter. Finally, no weird information, counter reset too. This is just my own experience. :wink:

Thanks Skylon…I will try “Reset Learnt Media” and then “Reset HyperTuning” separately.

Hope it will erase the ÿÿÿÿÿÿÿÿÿÿÿÿ weird information!!

Bad New…I try “Reset Learnt Media” and then “Reset HyperTuning” separately and
the ÿÿÿÿÿÿÿÿÿÿÿÿ weird information still there…

As I mentioned before, may be this only works in Original BenQ drives and not in tha newest Lite-ON ?

Any other suggestion will be appreciatte!!

Thanks for help!