Benq DW1650 DVD-RW weird read error

Can anyone help me out with a problem I’m having with my Benq DW1650?

I recently bought myself a set-top Funai DVD Recorder which records to both DVD-R and DVD-RW and I haven’t had any problems in playing and ripping a DVD-R recorded from my DVD Recorder with my Benq drive.

The problem I’m having is that I can’t play or rip a recorded Maxell 2x DVD-RW disc (recorded in my DVD Recorder) in my Benq drive. This is the error that DVD Decrypter gives me:

And this is the error that PowerDVD gives me:

And the disc status in My Computer:

Drive (F) is my Benq DW1650 drive.

I’m not sure what’s causing this because I tried the same disc in my LG GSA-5163D on my other PC and the disc played in PowerDVD, DVD Decrypter ripped the disc to the hard drive and My Computer was showing the disc as using the UDF file system with the total capacity of the disc being 0.99 GB. :eek:

Could this be a firmware problem? Both drives are 16x DVD ReWriters so I’m not sure how firmware could come into this.

I think I should also mention that InCD and Nero 6 are installed on the PC with the Benq drive but it’s not installed on the PC with the LG drive.

Anyone got any idea on what could be the problem? :confused:

Uninstall that InCD. Did you finalize that disc with your Funai dvd recorder?

Yeah the disc has already been finalised with my DVD Recorder.

Before I uninstall InCD, it is absolutely necessary to uninstall it? I use it all the time to erase my DVD-RW discs so that I can re-use them.

You don’t need InCD to erase your DVD-RW discs. There are other free programs that can erase DVD-RW discs. Use ImgBurn. I’d uninstall the InCD which is known to cause problems with other software. :wink:

I’ve uninstalled InCD. But I’m still having the same problem.

I also forgot to mention that on the packaging for this disc, it says “DVD-RW ver 1.1 With CPRM”.

The Benq drive definitely supports CPRM discs:

What I don’t get is; why does my LG drive recognise, play and rip the disc without any problems and the Benq drive fail to recognise the disc at all? :confused:

Any and all suggestions greatly appreciated.

I’m now using a Mr. DVD branded DVD-RW 2x speed disc and used it to record a Terrestrial Analog TV programme in my DVD Recorder. This is what the packaging looks like:

I’ve tried putting this disc into my Benq drive (with the recording) and this is where it gets even weirder:

I’ve tried the same disc in my LG drive and have had no problems in reading, playing the disc in PowerDVD and ripping the disc to the hard drive.

I think this is confirmation that my Benq drive is the problem. But I still can’t put my finger on what the problem is exactly.

And in case you’re wondering why Nero CD Speed shows Mitsubishi as my DVD Recorder; apparently my Funai DVD Recorder uses a Mitsubishi chipset.

I would appreciate your suggestions on this.

The screenshot in the QSuite Shot shows that the CMCW02 is not supported in the BenQ 1650 firmware. You will have to get new media.

That doesn’t make sense because I backed up one of my DVD movies onto the CMCW02 disc and had no problems in writing to the disc, playing back the disc in PowerDVD and ripping with DVD Decrypter.

The problem comes after this disc has been Formatted and Finalised in the DVD Recorder.

It was just a guess to try and help because the QSuite Screenshot clearly shows that the media table is unknown. It was the only thing i could see. Maybe the drive is starting to go south? QSuite also showa that the disc capacity is only 14 mbs so maybe the problem is bad media.

This MID should be supported:


Media Code Speed Edit V 1.0.8.8
------------------------------------------

Firmware: BENQ    DVD DD DW1650   BCDC
Bootcode: 
------------------------------------------

Overall supported media types:  269
(...)

DVD-RW  supported media types:   39
------------------------------------------
[B]CMCW02          2x[/B]
CMCW03          4x,2x
CMCW04          4x
CMCW04          6x

It seems as if Qsuite treats rewritable media in a different way.

Michael


Have you had trouble in playing back and ripping that particular disc, mciahel?

Do you by any chance, think that this may be a firmware problem?

Problem solved.

I upgraded the firmware for this drive from BCDC to BCHC and the drive now reads, plays back, rips and scans the disc without any problems.

Some screenshots of my success:

I think this scan (above) is actually quite good considering that this disc has been erased 6 times already.

The CMC disc (below), I tested to confirm whether my DVD Recorder was turning CPRM on or not. And it turns out, it isn’t.

What I don’t get is why didn’t the BCDC firmware read these discs? I mean, it’s a newer firmware when you compare it to the A103 firmware of my LG drive, where the disc worked fine. :confused:

This sort of thing just shouldn’t happen when you’ve only had your new DVD Rewriter for a few months. :disagree:

But at least this thread can be used by others who experience similar problems. :wink:

**sorry posted at 4am, half asleep and didnt read whole thread **