BenQ DW1650. Doesnt read any media

vbimport

#1

My computer recognizes the burner. But when i put a dvd in the drive nothing happens except the light keeps blinking. When i try to open the drive in “my computer” while a DVD is in. it causes “my computer” in task manager to stop responding.

I just got the burner, I have uninstalled all burning and backup software, updated windows… Tried it in another computer… same problem doesnt notice the dvd and causes “my computer” to stop responding.

Should i just return it and try my luck with another one.


#2

What type of DVD? Blank, written or commercial?


#3

Blank DVDs, Movie DVDs doesnt want to read anything.


#4

did you set the jumper on the drive correctly when you installed it?

did you connect it to the appropriate connector on the IDE cable?

if oyu jumpered it as master, connect it to the END of the IDE cable.
if you jumpered it as slave then it belongs on the middle connector.


#5

Yes all that was done. Its set to Primary Slave. With my Dvd Rom is the master on the same IDE.


#6

does it say it’s set up ok in the device manager? no yellow exclamation marks or anything?

right click on the driv ein the device manager and click “uninstall” then reboot this may not help, but it certainly can’t hurt.

if it’s a brand new drive i wouldn’t spend TOO much time troubleshooting it if you can just get another one under warranty. if the second one acts up then you know the problem has to be on your end though.

maybe someone else will have other recommendations, but normally when it’s a new install it’s a jumper/connection problem or the drive didn’t install itself correctly.

just to double check, do you have an 80 or a 40 wire IDE cable?

it might be worth trying to stick the benQ as master and the dvd rom as slave just to see if that makes a difference, but like i said, i wouldn’t go crazy since it SHOULD work if you connected everything correctly. optical drives don’t require drivers or anything (as long as you have XP and you said you just got the latest updates, so yeah…)


#7

yes everything is correct in device manager. i tried both a 40 and 80.


#8

little off subject, should i get a replacement or try another burner out.


#9

if it did the same thing in both computers and you’re sure you jumpered/connected it correctly, then I’d say send it back.

did you get it from a retail store or online?

this is probably the only advantage to a retail store…quicker turnaround time (ie immediately) for return issues.


#10

you mean a different model? I’m a benQ girl so I think you should just replace it. then 1650 is a very good drive (if you can get it to work!)

i think you may have just gotten unlucky with a bad drive.


#11

That happens to the best of manufacturers. Juust get a replacement and see if that works.


#12

I got it from newegg. I will just get it replaced and hope that does the trick. Thank you for the help.


#13

Hi! I have the problem with my BenQ 1650 as you stated. The USB Mass Storage appeared in Device Manager with a yellow exclamation mark.
I tried uninstall it, reboot, it’s still the same.
I also tried on both laptop and desktop. I want to use it for my laptop

Should I go exchange my BenQ or is it because of my external enclosure.

Also, does BenQ work with NEC chipset, Prolific chipset, Cypress chipset?


#14

It’s already been suggested to you an9891gel that it’s probably your external enclosure. Also we have suggested to you do a search in here regarding external enclosures. The enclosures with the prolific chipset seem to be compatible with BENQ drives.


#15

in your thread i recommended that a mroe compatible chipset (PROLIFIC) would solve your problem but you and other posters continued to troubleshoot so I left that thread. my recommendation on your problem still stands. I don’t think your drive is compatible with your enclosure.

also, hijacking others’ threads is not nice.


#16

Do you have any of the programs that bypass copy protection running in the background?? Like DVDIdle Pro or AnyDVD??? And make sure you set the region for your drive to the appropriate region you are in. If you have DVDIdle pro or anyDVD running in the background, I suggest you remove it. And what DVD player software are you using??? Try a different DVD player software to see what happen.