BenQ DW1640 recording issue

Hi,

I’m having an unusual problem with my 1640s which I couldn’t find a reference to on the forum. I’m hoping someone can help me out. A little background:

3 x DW1640 originally BSKB now BSMB

  • one master connected to onboard Canterwood i875 ATA100 controller, two connected to ITE 8212F RAID/ATA PCI card w/ ATAPI BIOS as masters on separate channels.

Windows XP SP2, MS SPI layer

Everything started out working fine, all 3 drives could burn and I didn’t have any issues with the setup aside from my TYG01 media burning only at 4x (prior Pioneer DVR-108 owner with >NIL’s f/w as you can tell)

So in hopes of getting to 8x I tried to use MediaCodeSpeedEdit 1.0.7.2 with BSLB firmware. What I did was remove speed restriction and alter one of the unnecessary media IDs changing it to TYG01 and setting the write strategy to TYG02. Strangely enough the speedpatched upgrade did not have any effect on the drives. They would still only show 4x as the maximum allowable speed on TYG01 media in Nero 6.6.0.16 and DVDDecrypter 3.5.4.0.

Thinking that maybe during the actual recording session the speed would increase I tried burning a full SL DVD-Video image with DVDDecrypter. The drive would just sit at lead-in and not do anything for 10-15 minutes. I could hear the disc spin up in the very beginning and the light would start blinking but there was absolutely nothing else going on. Moreover, if I tried to run any application like Explorer, Firefox or Total Commander it would not start up and the process would show up as “not responding” in task manager after a few minutes. Naturally, the burning drive would be locked up and the only way to get the system to function again would be hard reset.

I tried burning on all 3 drives with the exact same result. Whether it’s burning something or erasing a DVD+RW disc, the application would just sit there with the drive doing nothing other than blinking the light and the time counter going in the burning software. Both Nero and Decrypter do the same thing.

Flashed the drives back to stock BSLB, cleared media tables in QSuite 2.1 and only one of the drives can burn now but not I’m not so confident in the quality of that burn. I recorded a 2 CD XVID and my Philips DVP642 reported a disc error on the second file which never happened to me before.

Flashed up to stock BSMB last night but still no dice. Only 1 drive out of 3 burns. BTW, all drives read discs just fine in Nero CDSpeed. Any ideas or am I pretty much out of luck with this one?

Sorry for the long post.

[b]Cliff’s Notes:

  1. 3 x DW1640 drives
  2. Flashed to speedpatched (MCSE) BSLB
  3. Drives refuse to burn, stuck at lead in, can’t launch anything in Windows
  4. Drives read fine
  5. Flashed back to stock BSLB, only one drive is capable of burning
  6. Flashed to stock BSMB still only one drive burns[/b]

Thank you again, I hope someone can shed some light on this.

There’s no TYG01 in the firmware so I don’t think you can do that (take another ID and save as TYG01) but I might be wrong. Haven’t play with MCSE for a while except the speed patch.

You are correct, that’s why I took another ID of media I don’t use and imported a TYG01 tag straight from DVD Identifier in its place. After that I set it’s strategy to TYG02. Seemed quite logical and from what I read that’s how others did it as well.

Try stock BSLB or BSMB with SolidBurn on perhaps? I’ll take a wild guess that the drive that works is the one connected to the onboard controller? I would first off all try removing the ITE 8212F controller. Try the drives 1 at a time connected to the onboard IDE.

Q.

Hi :slight_smile:
I use the ITE controller without any problems.
If wishing to use multiple drives, then I suggest BEFB f/w (it’s the one I use)
this gives UDMA 4 when used internally (BEFB is primarily aimed at external use).

I’ll agree if the drive that works is connected to the ITE. But if both malfunctioning drives are connected to it… see my point? Remove it, test all drives one by one.
Another way would be to switch the working drive with one of the faulty ones, see if the working drive continues to work, or if it breaks and the faulting one suddenly starts working again. It’s all about elimination. :slight_smile: A Nero Infotool log could prove useful too.

Q.

Hi :slight_smile:
Qyngali wasn’t suggesting that your idea wasn’t worthwhile. Just pointing out what works for me. However I should have added to update both the bios & drivers for the card.

Well, the UDMA2 bottleneck for multiple drives is not the issue as I had them all working together before with BSKB in the same exact configuration off the ITE controller. Plus they’re all masters residing on their separate channels so that also should provide enough headroom.

What I ended up doing was indeed flashing with BEFB in .CVT form using WinDWFlash because the executable flasher didn’t work. After that all drives started working. Strange huh?

Also, would you guys recommend having solidburn turned on by default on all types of media with BEFB?

Hi :slight_smile:
Flashing BEFB is a crossflash, drives ID now 164B.
I personally have Solid Burn ativated for both known & unknown media. Along with WOPC I feel this compensates for the variation often found in media these days even when sticking to same brand. OverSpeed appears to produce read problems for some, if you experience this turn OS off.

Zebadee,

I decided not to overspeed so I won’t need that setting. Do you think that if I go back to BSLB which is probably the best balanced f/w ATM, do you think my issues will come back or maybe this crossflashing you speak of cleared something internal up? Thanks

Hi :slight_smile:
I’ve found that either crossflashing or going back to a f/w that has no SB/OS support appears to have a cleaning out effect. Hence on return to preferred f/w, it is often reset to virgin status. The only way to find out for sure is to try it.

Well, here are my findings:

  1. Flashing back to stock BSLB breaks the drives again so I’ll have to stick with BEFB
  2. I get a 97 score on TYG01 regardless of burning at 4x (OS-off/SB-on/WOPC-on) or 8x (OS-on/SB-on/WOPC-on).

At 12x w/ OS get a consistent 96 but I feel that the time gain in this case is not worth it.