Benq dw1620 Problem

vbimport

#1

Hi all,

I recently purchased this drive OEM and hooked it up to my computer in a slave configuration. Windows detects the drive correctly as a benq dw1620 and installs a generic windows driver. The problem comes when I try to do anything significant with the drive. Playing an audio CD does not work, nor does playing a DVD, nor does copying files from a disc to the hard disk. Sometimes windows gives me a cyclic redundancy error, either way the drive continues to have the light flash as if it is trying to read the media. I RMA’d the drive and now have installed a new one only to have the exact same problem. This leads me to believe it is a compatibility or configuration problem.

When I try to connect the benq drive alone as master my computer won’t even post … it hangs at check RAM.

Ultra DMA2 is enabled in windows and my CDRW drive that is the master is working perfectly fine. I have an MSI kt6 mainboard (a Via chipset). Anyone have any ideas? Any help would be appreciated.


#2

Normally if it hangs during Post the jumper on the drive is not set properly. Maybe try putting the BenQ as master and don’t connect the CDRW just to test and see if the drive works ok on it’s own. You said generic Windows drivers when you look under ATA/ATAPI controllers in your Device Manager does it say Standard Dual channel PCI IDE Controllers?


#3

If you’re getting cycle redunancy errors it could mean the dvd disc is scratched. You may want to install the latest VIA chipset drivers.


#4

I already put in the latest Via chipset drivers and as for the ‘Standard Dual channel PCI IDE Controllers’ I’ll check that out. On the next try I will pull out the CDRW all together, it doesn’t matter what part of the IDE cable I put the drive on right (as long as I use the master jumper setting).

Thanks for your help.


#5

Some IDE cable have cable select so it is best to use the end Black connector for master. Some People have problems with VIA drivers and some don’t. From what I have read on this forum most people use the VIA 4 in 1 drivers and have better luck with them.


#6

In device manager it says that I have “VIA Bus Master IDE Controller” not “Standard Dual channel PCI IDE Controllers.” Is this of any concern?

I’m going to try putting the benq in on its own as master tonight. Hopefully it works … thanks,


#7

Well if you have more trouble you can try rolling back to the Standard Dual channel PCI IDE Controllers and reboot, some ODD’s work better with STD MS drivers. Nvidia and VIA drivers can cause problems with optical drives.


#8

It worked … at least it is reading media now. I just have the drive as master on IDE 2 without the cdrw drive hooked up. Thanks so much for all the help :slight_smile:

So this can mean a couple of things right? Either the Benq doesn’t like being slave or doesn’t like playing with the NEC burner. I’m going to try to put the CD burner as slave and see what happens. If not, I’m sure I can deal with not having use of my CD burner now.

The cable going to the slave could also be bad right, but this is part of the same cable so it is unlikely.

Thanks again crossq.


#9

I have one BenQ as Primary Master and My Nec 3520 as Primary Slave and they get along fine so hopefully it will work for you, IDE cables are cheap so it wouldn’t hurt to change it if you run into the same problem. Happy burning.:wink:


#10

from what stores can i get a 80 pin ide cable and also what about the screws and the audio cable? from where can i get those?


#11

newtoburners, in any computer shop… :wink:

Hell, I’m sure you can even find it at Walmart.
(Note though, I’m not living in US).


#12

I am having a similar problem… I have a brand new DW1620… witch I found out is a bulk version, since it doesn’t state “BenQ” on the tray.

The drive has problems on reading files from cd’s… usually executable files, but not limited to this type… it often prompts me with CRC errors. But it’s not a problem with the media, since it doesn’t happen in other drives and also affects new media (audio cd’s, recently purchased games, etc). It also doesn’t burn dvd’s under windows (I was able to burn one dvd under linux… but not all linux distributions work: I tryed to install slackware and it couldn’t even read the installation cds…)

I tryed to fix the problems by upgrading the firmware. I then noticed that the firmware version was B7U9, witch is a firmware for the retail version (right?). Is that a problem??? Shouldn’t the firmware version start with G??? If it doesn’t matter if you use the G… or B… firmware, why are there two diferent versions in first place???

Anyway… the program that upgrades the firmware didn’t let me transfer the G7V9, so I upgraded to B7V9… And nothing changed at all…

I don’t know what causes this problem and what I should do to fix it… Should I downgrade the firmware? To witch version? How to install a G-firmware once the drive is already B-upgraded?

Or is it a compatibility issue? My motherboard is PCchips M863G, mobile Athlon xp 2400+, 512Mbytes RAM. The hard drive works fine (as pri-master… dw1620 is sec-master)


#13

I “solved” the problem by disabling the UDMA for the secondary IDE channel (using PIO only now).

Should I install the generic Microsoft driver for the IDE controllers for the DMA to work?


#14

Pio Mode is not the proper mode for your writer. I am not sure what chipset you have but running STD MS IDE drivers usually resolves most drive problems. As for the FW as long as you flashed properly there really is no big difference between G and B series. Don’t really have enough info. A read through the BenQ FAQ’s might help.:slight_smile: