Benq DW1620 Burning slow

Well, this is what’s going on:

I recently bought a Benq DW1620, then i bought some “Verbatim 16x -R” dvds…
When burning 4.2Gb (six 700mb avi files) to the Verbatim at 16x it takes me about 15min to burn it, and it often stops about 4/5 min in 1% bfore advancing.

Then i bought some “Sky 8x +R” dvds…
Same deal here… it takes me 15minutes to burn 4.2Gb at 16x, i doesn’t stop in 1% tough.

I don’t know much about dvd burning, i’m new to that matter, but lot of ppl told me i could burn 8x dvds at 16x with no problems. Anyway the “Verbatim” i used were 16x.

So… what kind of problem am i facing here?
Am i just having bad luck with the dvds i’m buying?
Is my recorder messed up?

Every review i see, every opinios says Benq DW1620 has excellent burn speeds… i don’t understand.

My DW1620 came with firmware B7U9 then i upgraded it to B7V9… same thing :frowning:

Need help… what should i do?
Thanks in advance.


Extra info:
Asus P5P800
Prescott 3.2
512Mb DDR400
Primary IDE: HDD1+HDD2
Secondary IDE: Benq DVD-RW only

Sounds like you need to enable DMA.

If think it’s set correctly… i’ve checked that in FAQ, it was already like it was supposed to be:


Sounds to me like WOPC kicking in. Have you tried putting in a blank and running the quick test in QScan for tracking errors and focus errors? Just because a disc is rated at a particular speed doesn’t mean the 1620 will agree. :wink:

Not that this would help with this particular problem, but you should set the burner to master. Having just a slave drive with no master on the same channel is not good.

WOPC slowing down a burn from 16x to 4x? Not likely. Back to the DMA, it might run in PIO mode even if device manager reports it as running in DMA mode. Known problem in windows. Possible solution here: http://forums.techguy.org/showthread.php?t=378767

Well, the problem wasn’t that m8, i did all the procedure, rebooted and then i burned 4.2Gb (six 700mb avi) at 16x and it took 17 minutes to burn it :frowning:

Someone help me plz… I really need to know what’s going on here…

Well is some cases a faulty drive was the reason why the writer would burn slow but there are a few things worth trying before coming to that conclusion

Set the 1620 as secondary master instead of slave

Replace the IDE cable you are using with it

Uninstall the secondary IDE controllers & the 1620 from the device manager and let windows redetect them

Install the official Intel chipset drivers

If already present uninstall the Intel Application Accelerator as it can interfere with DVDRW drives (note the IAA is not the same thing as the above chipset drivers)

Try the drive in another computer if you can to see if the problem persists

Defrag your HD

Since i haven’t solved the problem yet, let me give some more info to see if finally someone can help me…
I used Nero CD-DVD Speed and did a Create Data Disc test… i got this results, why am i burning at 4x??? I don’t understand what’s happenning here… i used “Sky DVD +R 8x”…
Someone help me please please…

Really crap media you got there… :confused:

Most probably the discs bare MID “VDSPMSAB001”, this media code is not present in your firmware (B7U9) and therefore the drive will burn them with generic write strategy at 4x speed (max).

To be able to burn at higher speeds on this media type, you have to use ala42’s MCSE and apply other write strategy.

Use DVD Identifier to get all information about any DVD media and your drives capability with media in question. :slight_smile:

You mean for example i can’t burn 8x dvds at 16x without changing the settings in MCSE?

Not if your F/W doesn’t jive with the Mid code of the media. Follow Pinto’s suggestion and you should be OK.

I would m8 but i didn’t understand what he told me to do, i’m very new into dvd burning, i don’t understand what u are talking about most of the times, can someone explain pinto’s suggestion in an easy-like-5-years-old way? Otherwise i don’t think i’ll get it :expressionless:

First get this DVD Identifier and let us know what your media code is with this identifier,

Media #1 : Verbatim -R 16x

Unique Disc Identifier : [DVD-R:MCC 03RG20 ]

Disc & Book Type : [DVD-R] - [DVD-R]
Manufacturer Name : [Mitsubishi Chemical Corp.]
Manufacturer ID : [MCC 03RG20 ]
Blank Disc Capacity : [2,298,496 Sectors = 4.71 GB (4.38 GiB)]

[ DVD Identifier - http://DVD.Identifier.CDfreaks.com ]

Media #2 : Sky +R 8x


Unique Disc Identifier : [DVD+R:POMSI002-01-000]

Disc & Book Type : [DVD+R] - [DVD-ROM]
Manufacturer Name : [Plasmon]
Manufacturer ID : [POMSI002]
Media Type ID : [01]
Product Revision : [Not Specified]
Blank Disc Capacity : [2,295,104 Sectors = 4.70 GB (4.38 GiB)]
Recording Speeds : [1x-2.4x , 4x , 6x-8x]

[ DVD Identifier - http://DVD.Identifier.CDfreaks.com ]

But they both take more than 15min to burn 4.2Gb @ 16x :frowning:

Forget the Sky media or use them for frisbee’s. Now do a search for ala42’s MCSE and it will show and tell you what and how to do it.

I alrady have that app but according to it i should be burning Verbatim -R 16x perfectly… but i’m not! Cause it also takes more than 15min to burn 4.2gb :frowning:

Hey Holland… I think we should see if we can get a Mod to bump you over to the LG forum. The folks over there would be more qualified to help you than I am as I don’t own an LG. How’s about that. Do we have a Mod that can accomadate a fellow Noob and move this to the LG forum please??? Or if not you can go here and see if you can find any thing similar to your situation.

http://club.cdfreaks.com/forumdisplay.php?s=&daysprune=&f=91

Are Verbatim DVD-R 16x made in Taiwan? i have similar problems with that media and BenQ DW1640… the good media is Verbatim DVD-R 16x made in India. In my case, i can burn with good quality but @16x ~ 11min :frowning: Like Sportfish says, forget Sky media. Maybe you have to use another media to know that it’s not a drive problem. Some people works very well with made in Taiwan Verbatim media but we have a bad batch of that.

That would be great.
If i can’t solve my problem soon i’ll take take it to the store on monday and trade it for a Pioneer, i don’t care if i’ll look like a fool but at least with the Verbatim 16x it should be burning fine and it’s not!

Did you move the drive from slave to master?