Benq DW1620 Burner

I have a Celeron D 2.4 GHz
512MB Samsung DDR RAM
Asus P4P800 SE motherboard
Asus V9400 X Series video card
All with latest drivers and BIOs updates and all work fine as have been previoously tested.

After a little while of computer usage, if I put a CD or DVD, doesn’t matter if it’s burned, commercial, etc., it will give a blue screen with error code C2.

I’ve had the burner replaced with no change in results. I have an audio cable connected to the drive. I have the G7V9 firmware on it already. I’m using Intel IDE drivers.

Please HELP ME!!!

Try running Memtest and see if there is anything wrong with your systems RAM.

Have you tried changing the IDE cable ?

If you have the IAA (Intel Application Accelerator) installed uninstall it.

It sounds like it could be a software problem a clean install of XP could solve that, plus have you tried scanning your system for any spyware ?

RAM is fine, passed Memtest as well as having been replaced not too long ago as well. Definitely no spyware or viruses. Will try switching IDE cable, but trying to avoid clean install of XP if I can. I will reply if no luck. Thanks.

Any new programs installed lately? Daemon tools?

Check out this M$ KB article.

I have the same ASUS P4P800SE mobo’s with IAA installed. I’ve had no problems with it installed on my computers. I would suggest you use the latest IAA drivers from the Intel website. There are others who have had problems with it installed but it was other software that was causing problems. As suggested you may have to do a clean install of XP which is one of the reasons why I hate XP with a passion! :stuck_out_tongue:

P.S. check your power supply too. there are others who have said the 1620 is power supply picky. :wink: run a test on your hard drive as well. :slight_smile:

I’m not sure power supply has anything to do with it.

When I first bought a BenQ1620, I installed it in my old box, which had a PSU of 300W, if that, and I never had any problems; and I’m running 2 in my current Dell box no problem.

  • Jie

Others have posted problems with using low power supplies with the problems disappearing after upgrading to higher wattage ps. That’s the reason why I suggested he check his power supply. Everyone’s pc does not have the same configurations or same hardware. What may work for you may not work for others. Example: One member posted he was using a PIII 700 or 933 mhz processor. He asked if installing more RAM into his pc would speed up the burning process. I told him with my experience using a PIII 933 pc with only 512mb of RAM I was only given the option to burn up to 12x spd. Well, he proved me wrong because he installed more RAM and was given or able to burn up to 16x spd.

Dvd burning on computers is not exact science as we would like it to be because there are too many variables. :wink: :slight_smile:

Uninstall Intel IDE drivers and use the Microsoft standard ones.

Their is no need to remove the IDE drivers Intels play nice with optical drives it’s the IAA that causes trouble I know for some people like DVD_ADDICT it can work fine with DVD writers just like nVidia’s SW IDE drivers but I’ve seen more cases where it has been the cause of the problem then not.

Jerjef install these Intel Chipset drivers as they are WHQL signed just in the off chance it might solve the problem and avoid a format/clean install of the OS.

Well I tried the Intel drivers suggested, still no luck. But when I don’t think it’s the IDE cable connected to the drive becase in safe mode the problem is non existent suggesting indeed a software problem, but while in safe mode I took a tally of all the processes running and then in normal mode I started removing things from the list until it was the same as safe mode and still it happened. Now you make mention of IAA, how do i know if that’s installed? And if it is, how do I remove it?

You can check by going to your start button, click on RUN, type regedit, go to HKEY LOCAL MACHINE SOFTWARE. Look for INTEL as you can see in the pic I provided. Right click on it and click on delete if you want to delete the IAA. I would seriously think about reinstalling your OS if deleting the IAA doesn’t work. Did you use the latest IAA drivers from the INTEL website? If not I would suggest you using the latest drivers and see what happens. Good luck and let us know what happens.


Well I tried updating the Intel drivers and also removing the Intel entry from the registry as previously mentioned to stop the IAA with still no luck. Besides the dreaded O/S install again any other suggestions out there?

I think the last thing would be to take your 1620 drive and install it on another computer if that is possible. If it works on another pc then it’s time to bite the big bullet and reinstall the OS on your pc. :wink: