Benq DQ60 (I/O Magic) from Staples Firmware GREC

I downloaded firmware MREC:
http://www.benq.co.jp/data_storage/firmware/MREC.zip

But I cannot upgrade it. Message:
“The drive is not allowed to be updated.”

Does anybody have the same problem?

Thanks.
Simpleguy

The DQ 60 is not a real BenQ but it looks like you got a generic firmware. It is possible that the bqflasher program would fix the MREC firmware to allow it to flash the generic drive but I am just guessing here. Wait a while and see what others have to say. In the meantime, there should be no difference between the two firmwares so you don’t really need to crossflash until the generic versions are supeceded by the other version.

Welcome to the forum. You might ask here if the bqflasher tool works on the DQ 60:

http://club.cdfreaks.com/showthread.php?t=149980

Thanks.

“Still a few bugs in the system…”
Reasonable amount is the job security. If too many, your boss may find a better guy.

Simpleguy

I"ve the same problem, bqflasher wont do it, Win DW Flash wont do it either. Need to find a cvt. firmware file for a DQ60. I’ve been looking all day and cant find one. With the “G” firmware Qsuite wont work, no bitsetting, and no scanning with CD/DVD Speed. To me the DQ60 is just a so/so burner at best, but without all the tools the drive is useless. I guess I will return it tomorrow.
:a :a :Z

Same problem here! have been searching for F/W that work, but no luck, hopefully someone can help,

excuse my newbness, but I just ordered one of these at staples.com and am very interested also. could you use the Plextor 750 firmware? it comes as a .cvt file?

Maybe, I’ll have to try. Where did you see this?

Hi :slight_smile:
Usually you can just unzip plextor f/w, which will give you the .cvt file.
Use something like winrar. The result will be (see pic) This should work as 750 is based on the same Panasonic/Teac as the DQ60.

http://www.benq.co.jp/data_storage/firmware/MREC.zip

I used the same F/W upgrade & had no problems! Sorry to hear… :frowning:

Hi zebadee.
Tried that too. Starts to flash then comes up with “checksum no match”.
Everything I’ve tried like BQFlasher and WINDWFlash and the stock MREC firmware either comes up with “drive not supported” or the checksum error.
I’ve done two 1620 drives with “G” firmware to "B"with one of this flashers with no probs at all. Never could go from “G” to “B” with stock firmware.
I’m wondering if it has to do with different “G” firmwares on some of these DQ60s or maybe they are using different chipset.?
:confused:

I am not surprised as DQ 60s are not BenQ so BenQ tools will not work. I would have to say that DQ 60 owners will need to be content with G firmware until Quickee has the time to see if the chipset can be adapted. Too bad BenQ still thinks G is a good idea.

Hi :slight_smile:
Unfortunately I don’t have either drive (750 or DQ60). So I’ve only been able to go by a combination of reviews & spec provided by manufacturers. There have been some users who appear to have achieved crossflashing without problems. Hopefully they will come to your aid.

Thanks for all the input everyone. I think I will just return it. Didn’t want a DQ60 anyway. Was hoping that they might be 1640s. Too high of hopes I guess.
Thanks again,
wobble.

since i heard ppl are getting benq dq60 at staples i decided to grab one myself out of boredom. with the GREC firmware, i tried burning OPTODISC R08 since dq60 allowed me to burn this media @ 8X. even benq 1620 have problem burning this media. end result looks pretty good. burn quality surpass both nec 3520, nec3500, and 2 of my benq 1620. I used nero cd-dvd speed to set the booktype and it worked.

dq60 for $13, the future looks pretty bright to me.


Wity, did you have to upgrade the firmware? If you did what did you use and where can I get it? I’m a total newb and this is my first DVD burner so tell me all the details.

Thanks.

nope, i didn’t upgrade the firmware. i used the drive as is

How can you tell what drive you are getting? The picture looks like a BTC on all the boxes in my area and I thought the DQ60 has DVD-RAM write. Boxes make no mention of this.

BWigg, I have never seen the box with btc inside, so not sure how to detect from just the box. anyhow, windows detects dq60 as a DVD-RAM drive. I have it connected as slave (jumper on cable select) on the same ide channel with plextor 712A. dq60 operates in UDMA mode 4.

why does the image show benq DW1620?

DQ60 cant scan quality scan with media. So a BenQ 1620 was used. The media was burnt on a DQ60 though