BenQ 1655 - Lightscribe issue

vbimport

#1

Hello all … I’m a newbie here, so please forgive my newness …

I’ve done a search and found some info but I’m still stuck …

I’ve recently purchased a BenQ 1655 burner along with a NSpire enclosure (NSP-525C) here in Canada. The burner comes with OEM Nero 6 sw. I’m using Firewire to connect to my Toshiba laptop.

Using the enclosure, the burner works fine when reading as well as when burning. I’ve only been burning some DVD+R - with no problems.

My problem has to do with the Lightscribe feature. I’ve tried both Nero’s CoverDesigner as well as the trial download version of SureThing and the same issue arises.

When attempting to print a Lightscribe label, in CoverDesigner, for instance, there’s a long … long … long pause … then the lightscribe print dialogue appears and my 1655 appears in the drive selection pulldown field … at this point I’m thinking everything’s ok … so I select “Print” … another long long … long pause … A status message appears in the dialog stating “Waiting for drive to be ready” … Another long pause … and then I get an error popup with a message along the lines of … “Current software stack version not compatible with selected drive…”

ok, so I figured I was having the same firmware issues I had read about. I’ve found several different later versions of firmware … from Nero there’s a .67. … from SureThing, I found a .83. I believe it was … I’ve tried all of them and still have the same problem …

I must be doing something wrong.

The procedure I followed to update the firmware was:
(1) download the firmware update install package.
(2) restart in Safe mode
(3) in Safe mode delete the …/Common Files/Lightscribe directory and empty recycling bin.
(4) restart in Normal mode - ensure none of the burning sw is running
(5) install the firmware update
(6) restart in Normal mode …

help :doh:


#2

gollywoggle, welcome to cdfreaks. :slight_smile:

After a little research, your case Nspire NSP-525C comes with Cypress AT2 chipset but that might not be the case. Many recommends Prolific PL-3507 chipsets though.

Since you did not specify which firmware you have, so here are some things I would suggest you to try:


#3

thanks :slight_smile:

I updated the drive to the lastest firmware and updated the Lightscribe host software as per your link and I still had the same problem using the drive in my NSpire enclosure. I popped the drive and installed it into my PC … installed OEM Nero 6 … updated the Lightscribe host software … and presto!! … It works!

I’m heading back to the shop with my enclosure … they want to “test” it …

thanks again :slight_smile:


#4

I know that the Prolific chipset works fine with Lightscribe as that is the enclosure I have here.

External enclosure chipsets are very picky with optical drives so you may need to take the optical drive etc with you to prove to them it does not work fully.


#5

The shop called me back today and confirmed that the enclosure won’t support Lightscribe … The challenge now is to find an enclosure that uses the Prolific chipset. It seems the shops here in Toronto that I’ve scoped out all carry problematic enclosures … well, problematic for lightscribe atleast … lol …