BenQ 1640 Read Problems - Defective Drive?

vbimport

#1

Hello all,

I’m experiencing read problems with my new drive. Specifically: The drive starts reading, quickly ramps up to 4x-7x, then drops down to 2.4x-0.6x, and keeps doing so for the duration of the read. It returns similar results whether reading single or double-layer media.

My firmware is BSKB.

I’ve verified that the drive is set to DMA.

I’ve tried the MCSE speed-hack - no change (perhaps it starts off a little faster, but I really can’t tell).

The drive <b>burns</b> full speed without error (12x overspeeded Taiyo Yuden).

Is the drive defective?

Thanks in advance for your kind assistance!


#2

Yo

After you installed - did you go into Control Panel = Hardware - Device Manager - IDE ATA/ADAPTI Controller - Secondary Channel - Drivers - Remove/Uninstall the driver - close out and reboot?

If not - then you should-

Mike


#3

Wolfhour: Yes, I would say the drive is defective. My first 1640 did the same thing so I RMA’d it and am happy to say the replacement one works great and reads really quickly.

Mark


#4

Hi Wolfhour,

I also had the same problems as omote (maybe not as bad though) on my first 1640. It only did it for me when I used modded firmware to make it read faster. With stock firmware it worked fine. For some others though like omote, the drive may do this even with stock fw. I’ve heard of others also getting this problem as well with this drive, just bad luck.

I got another 1640 and no more problems. If yours is as bad as you say, you should return it I think for another. If you get a good one though, the 1640 is a great drive.


#5

Thank you (and everyone else) for offering your suggestions. I’ve reflashed twice with BSKB (I remembered that 2xflashing sometimes helps NEC drives, & figured, what have I to lose?), and the drive now seems able to handle ROM media - barely. It cannot however, read + or -R discs without the up/down read malfunction manifesting. :a

I’m convinced the drive’s defective & will RMA to Newegg. (This is my 1st Newegg RMA. Bleh.) :Z

Thanks again for your advice.


#6

I had the same problem as you and Roscoe and RMAd last week, I’ve yet to recieve the new drive yet but I’ll let you know.


#7

I see you used MCSE on your drive. Didn’t you void the warrenty :wink:


#8

I do not beleive this is a problem caused by MCSE and they have RMAd many drives before for others that have had documented problems not related to firmware, so I guess I’ll see.


#9

Well I totally missed both threads on the 1640 read problems and now that I have read them I guess it’s time to flash back to stock FW and replace mine as well because it’s doing the same.:frowning:


#10

I cannot believe the amount of people having this same problem with the 1640, I have to believe they know of this already and the new ones will be problem free(hopefully)


#11

BSHB seems to work quite well. May be worth a try to set it to that firmware.


#12

RMA time. My first drive actually did something similar, but I RMAed it mainly because it refused to read -R discs. BenQ quality control really sucks, especially with the Made In China drives. I don’t think you void the warranty unless your drive dies completely and can’t be reflashed before you send it in to genuine firmware.


#13

Unfortunately, this problem doesn’t seem to have anything to do with firmware whatsoever. I tried every firmware on my first 1640, and the problem remained unchanged at all. It’s a problem with the drives themselves. I agree with alan that it doesn’t seem to have anything to do with MSCE (or any other modding) either.

Personally I think alot more people also have the problem, but don’t realize it. Alot of people buy this drive for burning only, which these drives with the reading problem seem to do just fine. If you only rip with another drive, you’d never know the problem even existed. With how many people are starting to report this same type of problem, it seems like it may become a major issue with this drive. Benq is lucky it’s a problem with the reading and not the writing, or alot more people would notice and RMA their drive.

I’ve noticed also that this problem seems to vary as far as how bad it gets. Like for mine, it worked great with stock firmware for both reading and writing. Only screwed up when I turned the riplock off. Other people are seeing the problem reading even with stock fw speeds. Then of course others are able to turn off the riplock and read perfectly. Benq needs to seriously crack down on their QC control it seems. I think I just got a “weak” drive, and some are weaker than others.


#14

I’m not saying it caused the problem. Using non-Official 3rd party software voids the warrenty. Why return something like that. Just buy a new one :wink:


#15

Why not return it and let the shop (or BenQ) decide if they will replace it? You have nothing to lose by doing that. If they test it and decide it was caused by you using unsupported firmware, then you can buy another drive.


#16

Sorry to hear about your troubles and that they can’t be fixed. So far I’m pleased with my 1640 but I have only really done hardcore testing on burns and quality scans. I have not done extensive ripping, only a few DVD+RW’s, DVD-RW’s and a maybe a dozen DVD’s. Guess I should do more testing.

Best of luck in getting a satisfactory resolution.


#17

Not eveyone can afford to throw 50.00USD away, I agree with Dalen, the vendor can always say no. If they do do then so be it, but I beleive most good vendors will replace the drive if it is returned with stock firmware and not working properly.


#18

Well I just flashed to stock FW and did a read test and it works fine so maybe my drive is a weak reader at higher speeds. Really don’t think I need to exchange it though I would look pretty silly trying to say there is something wrong when it was not set to read that fast. Same disc with and without riplock. Riplock removed here Scan with Riplock below.



#19

Glad that worked for ya. Sometimes running stock, while not exciting, can hep in terms of reliability. :slight_smile:


#20

Yours seems to be about like mine was, but I got even worse scans when MSCE read speed was turned on, sometimes it even errored and stopped the whole process. But after many tests, stock firmware worked perfectly time after time. I didn’t RMA mine either, a friend of mine bought it from me. He knows all about the “problem”, but he doesn’t give a crap as long as it works with stock fw, and it does work quite well.

I however do care. Unlike my friend, I bought this drive mostly for it’s ripping capability (OK and writing too). Some people might say whatever just use it with stock, no big deal. But honestly it kinda sucks to read in a forum about how amazingly fast of a ripper it is, so I’m thinkin “hmmm, thats the ripper I want.” So I buy it, get this problem, and then it’s hard to return it (ethically) because it works with stock firmware. So, I’m stuck with a drive that I bought for fast ripping, meanwhile I have two rippers that kick its ass for speed already. Luckily my friend bought it from me, cause for what I bought it for, I woulda been throwing my money in a hole.

I think if I see these QC control problems keep happening with Benq, my next drives may be from someone else. You’d think after all those problems people had returning 1620’s, Benq woulda wised up a bit. They have great hardware, but whoevers putting it together (in China plant especially) needs to get their heads outta their asses I think.