Benq 1620 - slow!

The burst speed according to Nero DVDspeed is 0.8MB/s, and burning a full DVD at 12x takes about 16 minutes, from what i’ve read it should be more like 7 minutes… I have tried the following:

  • Changed so it’s on it’s own IDE-channel (master). The current transfer rate is UDMA2 according to System/Hardware in Win XP, BIOS says it’s UDMA2 too.

  • changing cables, i have 3 different (all new and from different manufacturers).

  • updated to the latest firmware.

  • changing various BIOS settings (that shouldt matter in the first place, but tried it anyways, like memory settings etc). Also tried disabling the different automatic settings for the DVD and selecting UDMA2 manualy instead.

I also tried disconnecting the drive and connected an old CD-ROM to the same cable and it’s burst speed was 20MB/s, reading the same (audio)CD on the 1620 gave similar results, 18MB/s. I have no idea if this is too low also, but i think i’d mention it.

Is there anything else i can try that you can think of?

What brand of dvd media are you using?

And what are you using to burn?

I’m using Nero, burst speed is the same for every media i have tried in Nero DVDspeed.

Can you go to Nero info tool>Configuration click the save/Floppy to save a log file and post as text under manage attachements so we can see your system, Please ensure you remove any serial numbers you don’t want the world to see.:wink: Also best to leave your BIOS IDE settings set to Auto.

Here you go.

Thanks for the additional info Rusk. :slight_smile:

Your Nero InfoTool is rather old and I hope your CD-DVD Speed is newer. You can upgrade both here.
InfoTool tells us your 1620 shares the IDE channel with 80GB HDD…

The actual burn speed depends on many parameter, one of them is media.
Even if you use 16x rated media it’s no guarantee your drive will burn them at 16x. Lack of support for this media in firmware (ie. limitation), system load, weak PSU or media itself being of low quality will limit your max burnspeed.

Burn a “data disc” in Nero CD-DVD Speed to see how well your media burns.

BTW, if you burn with Nero you can use this patch to show real burn speed.

Im using the latest version of dvdspeed. But i highly doubt it’s a media problem, I tried my original Unreal Tournament 2004 DVD and the burst speed on that DVD was 1MB/s, shouldnt it be more like 30+MB/s?

I attached the CD-DVD images.




Never tested UT disc in a burst test. On burned discs you should achieve ~23MB/s

Can you make a burst test (disc in drive, hit F6) with your RiTEK-R03 disc.

See this page how to save your pics of Nero CD-DVD Speed.

Lycka till (en=good luck). :wink:

Thanks :slight_smile:

The Ritek is 0.8MB/s…

Guess the only way to find out if the DVD-burner isnt working correctly is to try it in another computer…

Not sure if this will help, but I would install both hard drives on the primary IDE channel and the 1620 by itself on the secondary master. What burning software are you using as I see no ASPI layer installed so I am gueesing it’s not Nero.

The log says that Nero Aspi is not installed.

Re-Install Nero!

Thanks! You’re the best! That seem to have fixed the slow burning speed. I downloaded the Nero ASPI layer and now Nero burns a full DVD within 6 minutes at 12x, which is 10 minutes faster than before!

BUT as i suspected, it didnt do anything to the “burst speed” of the DVD, which still is only a super low 0.4 - 0.8MB/s instead of the more normal 30MB/s +. Reading DVD’s is ~1.7x speed no matter what medium i choose, which hardly is normal…

crossg: It was the first thing i tried, it didnt help to have it on it’s own channel.

Have you used Nero’s “Drivespeed” utility? You may have inadvertantly locked the drive to ultra low speed? :slight_smile:

Do you have ANY programs which automatically activate when a DVD is inserted, aka ANYDVD, DVD4FREE, windvd remote, creative diskdetector, etc. Maybe try disabling them.

How long is the IDE cable to the problematic drive to the mobo? Some cables these days are almost a meter long, and occasionnally can cause issues with signal degradation, which can affect sensitive (aka poorly designed/manufacured) drives.Maybe try using a shorter cable.

Could also be a corrupted/poorly operating aspi layer. (Nero has it’s own, but there is also a seperate system aspi layer)
Download the latest force aspi & install. Or perhaps go the other way & download killaspi.

Either way, it will either fix it, or force windows/programs to use SPTI (windows default access layer).

Just to clarify about “missing” Nero aspi (wnaspi32.dll).
If Nero aspi is’t installed on your compu you are not able to burn anything with Nero (see attachment). Test done on v.6.6.0.18.
Missing Nero aspi doesn’t effect CD-DVD Speed (v.4.10) burst test at all though.

Rusk, forget 30+ MB/s burst rate because it’s not possible if you aren’t using 162I (external) firmware.


I was able to burn just fine with nero without any ASPI layer whatsoever, but it was slower. That firmware with 30MB/s burst, is that something that’ll work on my drive?

Debro: No i havent used nero drivespeed, just to make sure i downloaded it and set it to “maximum”. The autorun for CD’s/DVD’s is turned off, i hate that “feature”. Force ASPI is installed since yesterday, but i dunno if it’s the latest version, i’ll check. I have tried 3 different cables, they’re about 40-45 cm.

I do remember one thing now! When i first bought the drive ( http://club.cdfreaks.com/showthread.php?t=144006 ) i was adviced by a forum member to use something called MediaCodeSpeedEdit.exe to get better read speed, which i thought sounded like a great idea(…)

It seems likely that MCSE made some error to the drive dont you think? I never checked if read speed was any better after the fw flash, at least i cant remeber that i did… so it’s likely its been this way since the patched FW flash. I did re-flash the drive a few days ago, but perhaps MCSE has done some error permanently to it :frowning:

Don’t think MCSE has anything to do with it but just in case you can reflash your drive with stock firmware.

What chipset does your mobo use? Download, unzip and execute this tool to identify.

off topic

I was able to burn just fine with nero without any ASPI layer whatsoever, but it was slower…
Checked with my son at home and he confirmed, Nero7 is able to display recorders even when wnaspi32 is not installed. Apparently Nero7 doesn’t need this file to burn and uses SPTI…? :flower:

Yeah i flashed it with B7W9.exe a few days ago.

Btw, MCSE says “bootcode revision ATAPI DVD DL 1600 FS02” shouldnt it read “DVD DD 1620”? hmm.

I have ALI-chipset… tried to download new bus master drivers from ALI’s site, but their download page has never worked for me ( http://www.ali.com.tw/eng/support/support_driver.htm
m5229 ), I even emailed them about this but they havent replied. Asrock doesnt have their drivers on their site either, they just have SATA-drivers :frowning:

EDIT: Um, here’s something i noticed Pinto, you use CD-DVD Speed and get 24MB/s, well guess what, i get the same :slight_smile: Using DVDspeed (which is what i have used all the time) i get 0.4-0.8MB/s… What’s your burst speed in that benchmark?

That’s the way it is. :smiley:

:confused: DVDspeed…?
To my knowledge we all here use Nero CD-DVD Speed. It’s also bundled with Nero7 (Start->Program->Nero 7->Verktyg->Nero CD-DVD Speed [on Win-swe]). :wink:

Well ok… it was probably just the damn program all along then (well except for the ASPI problem). I found Nero DVDSpeed via the forum so i thought that’s what you people used hehe

Many thanks for help guys, really nice and helpfull forum :slight_smile: