BenQ 1620 Not seeing certain media

vbimport

#1

Hi, I am new to this forum and I have a problem. I have had my 1620 since Dec. 04, burned roughly 100 dvd’s and just this week I started having problems recognizing some media. The only blank DVD I can get to work is the Fujifilm 8x DVD+R’s. I have tried TDK 8x, Sony 4x and even Memorex CD-R discs and everytime I put one if othose discs in the drive the LED flashes for about 10-15 secs and then goes out like there is no disc in the drive. The only disc that works is the Fuji. Before this I had no problems at all with any of those discs. My drive is a bulk OEM drive so I cross flashed it to the BENQ b7t9 version. The Fuji discs burn awesome but I cannot get it to read any other types of media. Is my drive going bad? Or is this a firmware problem or what? I cannot even burn a plain CD-R anymore. Extremely frustrating. If you need more info I will have to wait till I am at home as I am posting this from work. Thanks for any info…


#2

Let us know your system info.

In the mean time, here’s some to do list when you get home:

  • check IDE and power cables, sometime uplug and plug it back will “reconnect” better.
  • reflash FW and reboot
  • check dma settings, should be UDMA 2
  • check burst rate should be 22 mb/s or greater

hmmm what else…


#3

How would checking burst rate and DMA settings, which are set to UDMA, help in recognizing discs? I am running Win 2K. IDE and powere are good, using UDMA cable. Firmware has been reflashed numerous times. I just cannot get it to recognize blank media except for Fuji 8X discs. CDR and other DVD blanks will not show up. If you want me to get more info let me know. I am kind of a newbie on gathering the info so bare with me, thanks.


#4

I’m a total noob too, Retro6, and I share your problem (hence, my post). Nothing that was suggested in that post worked for me, but the members of this forum were incredibly helpful nonetheless.

Like you, I cannot seem to get my drive to recognize my blank DVD-R media. My drive does recognize my blank DVD+R media and even my used DVD-R media… just not the blank DVD-R’s. Just like yours, my drive’s LED flashes for approx. 10-15 seconds, then goes out.

The odd thing is that I found somebody (RiCKY2004) who was having trouble burning the same exact media in the same exact drive as mine, and when I did exactly what he did to fix the problem, it didn’t work for me…

Anyway, I apologize that I don’t have any answers for you as I, too, am in the same boat, and sinking fast.


#5

Have either of you contacted BenQ? I would be curious as to what they say. So you tried flashing with B7L9 and no fix?


#6

I have contacted BenQ and they want to send me a replacement after I explained my problem to them. It just seems very odd that the drive acts like a disc is present with Fuji 8X +R’s but not with any other brands of discs, whether its CDR or DVD-R or +R’s.


#7

Very odd…Go for the replacement i’d say.


#8

Wow. That’s great, Retro6! BTW, was your 1620 OEM or Retail? Mine’s OEM. I hope they’ll send me another one! And I really hope that solves the problem…


#9

I agree with Rolling56… If BenQ is volunteering to replace your drive, let them! BenQ has had some recent quality control problems and I experienced the exact same thing (DW1620 started acting bizarre after about a month in service). Anyway, I have a new DW1620 and so far…so good.

Go for the replacement. Once you get a good DW1620, you won’t regret it.


#10

Thanks guys, I will let you know what I come up with. Good Luck Auriel.


#11

Mine started by not recognizing some blank media, Pressed DVD CD’s and CD-R and then finally drive locked up and emergency eject was the only way to open the tray. This was after 10 days Retail verson.


#12

I did get a new drive and it was doing the same thing. So after reading some other posts here I put in a new PS and everything was fine. Very odd that a PS would cause this. Thanks for all the helpful info.