BenQ 1620 Issue

I haven’t really used it in a few weeks but today I tried opening it. It simply would not open. I rebooted and during the load up screen, I also tried opening it, it would delay respond and then pop open and open/close spasmatically (because I pressed the button a lot in windows). Then it would close like 1/10 of the way and sit there. I would then have to push it back in, and then after pushing it in, the light would blink and finally stop after 20-30 seconds.

Time for RMA?

Try to open it manually using a niddle or something else, through the little hole under the tray. I have read a few days ago that it worked for someone else. It sort of reset everything??!!

No go with the paper clip. The drive doesnt respond to anything in windows.

I guess it means RMA

The paper clip when pushed gently but firmly into the hole will activate a sort of lever allowing you to mechanically open the tray.
It has no action on the system or the engine.

How long does RMA usually take?