Benq 1620 installation problems under XP sp2 -- please help!

vbimport

#1

hi all, just got my 2nd benq 1620 from newegg today and had the same installation problems. I know theres a conflict with my current system because I successfully installed and burned a dvd on a different system today.

Current system im having problems with:
abit nf7-s v2, athlon 1700+, 1gb, 2 maxtor hdd’s on ide channel 1, aopen 1648 dvdrom and pioneer a05 on ide channel 2.

I take out the pioneer drive and install the benq drive. Bios recognizes it as a slave. I have two boot options: windows xp professional and recovery console. I select xp pro, get a black screen and system hangs. I have tried the drive as the master of both drives, slave of both drives, cable select option, and its always the same lockup. cannot boot successfully in safemode and have it work either.

I tried the benq as a master ONLY on ide channel 2 and it actually boots into windows. I get a prompt saying it found new hardware benq 1620, and then says found new cdrom, then system freezes completely. cannot boot successfully in safemode and have it work either.

i cant figure out what the issue is, but its definitely a conflict on my system. I would appreciate any help.


#2

It’s a conflict with the NVidia IDE drivers and an early BenQ 1620 firmware release.

  1. First, disconnect the drive and reboot.
  2. Go to the Control Panel->Add Remove Programs and select “Nvidia Drivers” and click “Change/Remove”.
  3. At this poing you will get a confirmation dialog box with a number of selections - tell it to remove ONLY the IDE driver and click “Remove”.
  4. Shutdown, reconnect the drive and reboot. You will be fine now.
  5. Finally, update the BenQ firmware to a more recent verson and then reinstall the Nvidia driver, since it’s significantly faster than the Microsoft one.

#3

My Nvidia drivers weren’t faster then the MS one, when I tested it in HDtach, actually the MS ones were just a hair better.


#4

Spartane, I have a DW1620 and I checked for “Nvidia Drivers” like you said above… When I click on “Change/Remove”, I only get this screen, tho:

I don’t have any option to just remove “ONLY the IDE driver”. Does this mean I don’t have the conflicting Nvidia IDE driver installed?


#5

You need to go into your device manager.


#6

Okkkkkk… Spartane specifically said, "Go to the Control Panel->Add Remove Programs and select “Nvidia Drivers” and click “Change/Remove”. " Was that incorrect?

Contorl Panel -> Add/Remove Programs is not Device Manager. ???


#7

i think ppl should read the FAQ before posting…this is getting too tiring…


#8

Go nto Control Panel then System then hardware tab then Device Manager. In DM go to IDE controller and double click on it and on the driver tab click “roll back drivers” and then click OK/apply.

We need to get a FAQ sticky.


#9

you guys are awesome, nvidia ide driver was my problem. I couldnt uninstall from device manager through because it would automatically reinstall it upon reboot. I was able to add/remove the nvidia drivers from control panel and select uninstall ide driver only (nforce v5.10). It installed the ms ide driver, i updated fw to B7U9RPC1, then reinstalled the nvidia ide driver, and im burning a dvd as we speak. Thanks again, great job guys.