BenQ 1620 in an external USB 2.0 enclosure

vbimport

#1

In this post I would like to share my experience about a BenQ 1620 OEM drive installed in an external USB 2.0 enclosure, chipset ALI M5621-A1.

I like only real tests, so I decided to check the writing speed in a real working situation.
The drive originally came with a G7L9 firmware and I could burn data DVD+R’s only at 4x even the allowed speed was 8x.

The next step was an update to G7T9 with the same results on DVD+R’s: SmartBuy 8x (PRODISC R03) and FujiFilm 8x (YUDEN000T02) media.

After that, I crossflashed to B7P9 and “QSuite 1.0” said that the drive is not supported, so I updated to B7V9 and everything has changed. QSuite 1.0 recognized the drive and I was finally able to write the DVD+R at 8x on the FujiFilm media but at 4x again on the SmartBuy media.

Surprisingly, the crossflashing to 47L9 (BenQ EW162I) and the update to 47N9 didn’t get better, even worse. The writing speed for both media dropped to 4x. I was thinking that this firmware is specially designed not only to upgrade the BenQ drive, but also to make some changes to the ALI chipset, which is the same in the original BenQ EW162I like mine.

Finally, I crossflashed back to B7P9 and upgraded to B7V9. I even tried to make a 12x burn on the FujiFilm media, because Nero 6.6.0.14 tells me that the max possible speed is 16x, but it failed. Maybe my transfer is not enough to support the 12x burn. Another interesting thing was that even I booktyped to the appropriate media with “BookType Management v8.4” in the OEM- G7xx versions, Nero said: Book Type automatically set to: DVD-ROM, while in the PRO (G7xx) and EW162I (47xx) Nero said: Book Type automatically set to: Current recorder settings.

In conclusion, I spent one day and wasted around 10 DVD’s to accomplish my experiment. I’m happy that I reached the maximum of my current configuration which is as followed: Compaq Armada M300, P-600, 320 MB, Fujitsu MHT2040AH-4200 rpm, BusLink USB 2.0 PCMCIA Card.

If you have similar or better results, I am ready for further experiments :)))

Regards


#2

cdfreaks.com has helped me so much in this, so I decided to make my first post ever.

I also got an OEM BenQ DW1620 and installed it first in an ALI external enclosure (PCMS or SYBA aluminum one, USB 2.0 only), knowing that the BenQ EW162I also used an ALI chipset. It was connected through the PCMCIA card. Hopes were high but I was dissapointed.

My first burn took 60 minutes plus to complete(1X-2X?). It came with the B7S9 firmware for some reason and I flashed it to B7V9. Got no improvement. I thought the slow burning might be because of the Verbatim 8X DVD-R (MCC 02RG20?), and so I went and got some HP 8X DVD+R and the burns got worsed, taking 90 minutes to burn comepletely. I went back to the Verbatims and actually got some coasters. The device buffer was really erratic when burning. I tried the 47L9 firmware thinking if anything, this would work. But they didn’t. From there I made a mental list of what was causing the slow, sometimes erratic burning.

  1. Computer was at fault (very unlikely since I have a good enough system)
  2. The USB 2.0 PCMCIA card is not being powered right or is of cheap quality
  3. The BenQ DW1620 is defective (very scary thought)
  4. The External enclosure is incompatible (likely cause)
  5. Everything was incompatible with everything (what it seemed like)

I did more research and found that the Prolific chipset might have been a better choice than the ALI chipset. I ordered a USB 2.0/Firewire Plumax enclosure with the Prolific 3507 chipset from Dealsonic.com and got an RMA# for the other enclosure. Hook-uped the Plumax and started some burns on the Verbatims. It got better, taking 30 minutes to burn. But still not good enough. Updated the Prolific chipset and it didn’t get any better. Thinking the PCMCIA card might be the system bottleneck, I wanted to bypass it by using firewire. After a long search for a 6-pin to a 4-pin firewire cable or adapter (laptop had 4-pin), I connected the drive through firewire directly to the laptop and finally got burns at 7 minutes, 30 seconds on the Verbatims. Burns were good with both B7V9 and 47L9 firmwares (currently using the latter).

The Verbatims can hit 12X but can’t stay there too long. My best burn yet took a little under 7 minutes going from 0% to 100% (counting Lead-in time and not Lead-out time). The Verbatims are rated at 8X but can be overburned at 12X, and right now, I’m trying to get it to burn very well at 12X.

I don’t really know if the problem was the old enclosure or my PCMCIA card, but I know the Prolific 3507 chipset with the Firewire works. I haven’t had a coaster since everything worked. I still need to do more tests. Qscan and Nero CD-DVD speed aren’t working correctly. This experiment took three days.

I recommend searching “prolific” at Dealsonic.com if one wants to see some enclosures with the Prolific 3507 chipset.

System: Compaq Presario 2100, mobile AMD Athlon 2400+ (1.79Ghz) w/ power scheme on “Home/Desktop” or “Always On” (sometimes crucial for performance), 704MB of RAM, 60GB Hitachi HD, SXGA+ display (1400x1050, pretty nice)


#3

I have a BenQ 1620 in an external enclosure with the Prolific PL-3507 chipset (updated to the latest firmware 2004.12.09).

The 1620 is currently using the B7T9 firmware as it allows me to burn at 12x to Fuji 8x DVD-R discs (TYG02 MID). I’ve tried the B7V9 firmware but it never goes past 8x when burning (as discussed elsewhere).

I have it connected via USB2.0 and Nero CD DVD Speed reports a burst rate of 20MB/s. This allows a write speed of 12x (typically about 6:40) and a read speed of about 15x (typically about 5:05).

I haven’t tried connecting via firewire mainly because I already have two external Maxtor hard drives daisy-chained off the firewire port. All burning is performed from these two drives and not the laptop’s internal hard drive.

The laptop is a Fujitsu E8020 with P-M 2.13GHZ and 1GB RAM. Both USB2.0 and firewire ports are ‘native’.


#4

i externalised a 1620 before in a prolific chipset casing via firewire. 16x was unattainable. 12x is ok.

some people suggest flashing 1620 using the usb2 model firmware, the 47XX firmware that is supposed to increase the burst rate. i tried also but still, 16x is a dead end, at most 14x++


#5

I have pioneer a08xl in prolific 3507 chipset enclosure i get burst rate of 24mb/sec on it but best I have ever gotten for burns is 12x, I think most enclosures are really meant for HDD not ODD even though they say ODD too. I also have an older oxford chipset enclosure with plextor in it, that I have never gotten to burn past 8x as the firewire burst rate on that enclosure is only 14mb/sec, both enclosure are cheaper kind with no flash chip so I have no way update fw, and believe me I did try.