BenQ 1620 does not recognize certain blank media dvd-r

vbimport

#1

Hey guys,
Im having trouble with my benQ DW1620 DVD±RW. It seems that with some blank media types (specifically memorex dvd-r 8x, and maxus dvd-r x4) the burner does not recognize the media at all.
The light on the front of the burner flashes for a few seconds, as if trying to read it, then goes out. When I go to check it out in windows xp, it says there is no media in the cd tray.
However, the burner recognizes my memorex 52x cd-r, and ultran 4x dvd-r’s. I know that the media that doesn’t work may not be of top quality, and may not read well, but the burner does not recognize it at all, which I would like to fix.
I have tried to remedy the problem by upgrading the firmware (I am currently using B7T9, however, I have tried various other firmware versions before such as B7S9 with the same unsuccessful outcome), checking if DMA is on (which it is), and checking the cables.
In addition, I have searched various forums such as this one for a problem/solution that mirrors mine, but to no avail. In any case, any help anyone could give me would be most appreciated.

Thanks,


#2

I just bought some Verbatim 8x DVD-R’s and still no dice…doesnt recognize it at all…wonder what is wrong with it


#3

As I am having the problem the writer recognizes the media, but produces bad burns, maybe you and another one having problems and me are the unlucky S-holes who got the drives produced or calibrated or quality checked when the workers had a really bad day …

Try to reflash the firmware in Windoze safe mode and otherwise be prepared to RMA the drive (which is what I will do with about 95% probability). My Benq appears to be very picky about the media - and even then does not burn well.

Are the Verbatim DVD-R 8x you bought made in Singapore or Taiwan? My Benq had a failed write on a Verbatim DVD+R and ugly writes on Verbatim DVD-R, all from Taiwan. I have 2 Singapore DVD+R I will try later, maybe they are better…


#4

the Verbatim’s are made in Taiwan,

And ive tried that reflashing procedure, but thanks anyhow. I think I will have to RMA the drive.