BenQ 1620 Burns SLOWLY

vbimport

#1

Hey guys,

I was hoping you could help me with a problem. I have had a BenQ DW1620 running the B7W9 firmware for a long time, with no problems. Just today, I tried to burn a Verbatim DVD (I have burned many of these before) and it took over an hour. The burns come out fine, and I double checked the speed settings. I’m currently using nero cd-dvd speed and getting a 0.29x transfer speed, UGH! Any suggestions?

Thanks


#2

Hi :slight_smile:
Welcome to the forum chado215. :clap:
Try this.


#3

Thanks zebadee,

One of the devices was set to PIO only, I’m going to restart my computer now and see if it works.


#4

Unfortunately,

When I run nero cd/dvd speed the transfer rate starts at 1.22x and promptly plummets to under 1x. Any other suggestions?


#5

Still having trouble,

I’m removing all the programs i’ve added to the machine since I last burned a disc. If anybody has a suggestion I’m happy to listen.


#6

Did you double check that DMA was enabled after restart? I’ve had Windows keep a drive in PIO until I forced DMA in the registry.

Have you tried copying CD’s or DVD’s in other programs like Exact Audio Copy or DVD Decrypter to see if it’s a Nero issue?

Did you recently install any programs that might be running in the background? Firewalls have caused me trouble. ZoneAlarm caused random reboots and slowed my connection down to about 25% of it’s original speed so I switched to Kerio, which I have to disable during burns to get my 1655’s burst rate high enough to burn at 16X.


#7

I doubled checked the ide channels, one was still in PIO mode although it was set to be DMA if available, the rest were in DMA mode. I only have the nero burner, I’m willling to download and try other DVD burner software (something that can just do data is fine). I have uninstalled all the programs that I have installed recently, and been checking the running processes for anything out of the ordinary. If it is the PIO mode problem, how can I force it in the registry?

Thanks,


#8

Check your DMA settings in the BIOS first.


#9

Where in the Bios should I check my settings?


#10

It’s hard to tell without knowing what is your system BIOS (Award, Dell, etc).

Did you delete the IDE channel and restart as suggested in zebadee’s link?

If you did and your 1620 is still in PIO mode, you might want to try doing it in Windows Safe Mode. If there is still problem, please post Nero InfoTool log here (copy-paste into your post, because attachment is currently not working).


#11

Find the page in your BIOS where your drives are listed. When you use the up/down keys you can press enter on the drive you want to change settings, and another page will appear. It should be on this page.


#12

Try this for solution and explanation of why it happens. It worked for me…

http://users.bigpond.net.au/ninjaduck/itserviceduck/udma_fix/


#13

Thanks guys, I got it fixed. I ended up doing what kerozene just suggested. There was nothing in the Bios about the DMA settings that I could find, and deleting hardware from the device manager wasn’t working either. I had to go into the registry and delete the IDchecksum for my BenQ drive and restart, then it worked fine. I would suggest putting this fix in a sticky with the other DMA problems, since this seems to be one of windows peculiarities. I really appreciate your help,

Thanks!


#14

You’re welcome!