BenQ 1620\1620pro problem

vbimport

#1

hi guys i was just wondering if anyone here could give me some help or info of any kind. I had bought a BenQ 1620 in January and it worked great with the media i was using up untill about 5 days ago. Then it would not read it at all. It would still read retail dvd’s, cd’s, cd-r and burnt dvds but not blank media of any kind. So i thought it was a problem with the drive so i went back to the store and they replaced it to a 1620pro. I brought it home hooked it up and then same problem as before, so now i know it was not a drive problem. Im just wondering if some of my settings might of been changed or something, or maybe its my IDE cable im just not sure. If any one had some suggestions or help that would be great.


#2

prolly media


#3

I dont think its the media. The media i had been using was mitsumi 4x dvd-r and i had no problems with it untill it stopped reading so then i tried some benq 8x +r media and it also did not read, and then i tried some FujiFilm 8x-r and again no luck in reading it


#4

Are those FUJI DVD-R media made in japan or taiwan? Big difference if they’re made in japan. What firmware is on the drive? B7P9, B7T9??? Also what software are you using to backup your dvds? Mitsumi isn’t the best media to use. Make sure you have the jumper settings correctly. Is the drive set to DMA mode? What are your computer specs?


#5

i’m not sure where the media was made it was just a disc i got of my friend so that i could try it to see if it was my burner or no. I have the latest firmware B7V9. Its on DMA ultra mode 5, and my computer specs are Athalon Xp2000+ 1.66 ghz 1 gb ram. When i started up my computer i notcied that it said my drive was on secondary IDE channel.So i switched it to primary but it still is set as slave with nothing as master? Would that have anything todo with it


#6

Set the drive as MASTER. download dvd identifier or dvdinfo pro to find out the media code on that dvd your friend gave you. good quality dvd media is the best to use with the 1620. you could try flashing the drive with the B7L9 firmware then flash it again with the B7P9. see how the drive works with the B7P9 firmware. you can download the B7P9 and other firmwares from here:
http://dvdpro.club.st/firmware/BENQ_FW.htm

you may flash in safemode as well. good luck and let us know what happens. :slight_smile:


#7

dumb question i know but how do i switch it to master? and thanx for all the help man


#8

your gonna have to crack open your case and look at the back of your drive.

you will see a little black jumper with 3 sets of pins

M,S,C

just set the jumper over the M and restart your computer.


#9

look in back of the drive a little jumper switch, move it to the master setting. i’m not at home so i can’t show you a picture of what it looks like. anyone care to help him out? :wink:


#10

thanx ill go look at it now and see if i can see what ur talking about


#11

i’m sure you will figure it out.

there’s only so many connections back there.


#12

yup i shut my comp off then took it out and put the little black thing over the M pins but still no luck. i think it is either my IDE cable or my computer, but i dont think it would be the IDE cable since it can still burn cd-r. i think ill try a reinstall of windows


#13

if you have another IDE cable lying around, try replacing the IDE cable (make sure it is an umda ide cable). And go into the CMOS, in the integrated peripherals, make sure you turn on all your controllers, and make sure you turn on the UMDA mode


#14

i should have added also that you need to plug your 1620 in to the end of the ide not the middle one.

the middle is the slave and the end one is the master.


#15

Well i tried a new IDE cable and still no luck. I think its stupid because it can read and burn Cd’s but it wont read/burn Blank media. I was reading another post and a guy had the same problem as me and when he changed his power supply it worked but i have no idea what my power supply is


#16

do you have another computer you can pop it in and check?


#17

Lo check your Power supply…and do not share the Power cord with any other device …only leave BENQ 1620 On…this should solve your problem…

i got same problem too


#18

I find it odd that it would be a power supply problem. I have a ANTEC true power 430 ps that houses 2 hard drives, a Plextor 708a dvdrw, Toshiba 1612 dvdrom, Benq 1620 dvdrw & a Liteon 811 dvdrw. I also have a ANTEC true power 480 that houses 2 SATA hard drives, 1 IDE 200 gb hard drive in a hard drive rack enclosure, Pioneer 107d dvdrw, Toshiba 1612 dvdrom & Benq 1620 dvdrow. The power connectors are shared, the 1620’s are not on it’s own power connector. I have no problems in reading/burning with the 1620’s. :stuck_out_tongue: :slight_smile: