BDC-TD03 Drive stopped reading/writing any Disc after buring a DVD

vbimport

#1

Hello ,
I have a Combo drive Pioneer BDC-TD03 on a Sony Vaio F12 with Windows 7 64bits, I was burning a DVD using Nero Lite , it reported a burning error and since, the drive stopped working altogether . I tried all kinds of media DVDs CDs, it always asks to insert a disc. I can’t boot with a bootable windows CD anymore so the issue is probably not related to drivers or registery.
I have looked everywhere for a firmware to try and flash it. couldn’t find it ! tried the microsoft Fix it troubleshooter also and removed it and put it back , the drive is detected and seamingly troublefree, but once a media is inserted it shows no life!
Is there anyway I can bacup the firmware and re flash it, I found a BDC-TD02 firmware on the sony support site , is it okay to flash it with ? Or could it be an issue with the lenses?

Any help is very much appreciated.


#2

Flashing a(nother) firmware will give nothing but make it worse!!!

It’s really frustrating to always read that fairytales from hardware error fixing by just flashing a firmware…


#3

Never flash firmware on a drive that is not working properly, tis not a magic cure!


#4

Yep , looks like its a hardware problem , I’ll try to find a replacement or an external drive.
Thank you guys for the replies !


#5

I had a similar problem, couldn’t play BD disks in my BDC-TD03RS, it was like the lens pack didn’t catch a proper position to read.

…Obviosly, seems a hardware problem… So, what to do?

Play with moving the laptop! put it upside down between the time you insert the disk and the the player start working… amazingly it works! (for me at least)

I Known it’s a crappy solution. But yesterday I couldn’t watch a single BD and now I’m watching “The Last Boyscout”…

Good day and good luck!