BD-R read, playback problem: Drive? Compatibility?

<!–[if gte mso 9]><xml> <w:WordDocument> <w:View>Normal</w:View> <w:Zoom>0</w:Zoom> <w:PunctuationKerning/> <w:ValidateAgainstSchemas/> <w:SaveIfXMLInvalid>false</w:SaveIfXMLInvalid> <w:IgnoreMixedContent>false</w:IgnoreMixedContent> <w:AlwaysShowPlaceholderText>false</w:AlwaysShowPlaceholderText> <w:Compatibility> <w:BreakWrappedTables/> <w:SnapToGridInCell/> <w:WrapTextWithPunct/> <w:UseAsianBreakRules/> <w:DontGrowAutofit/> </w:Compatibility> <w:BrowserLevel>MicrosoftInternetExplorer4</w:BrowserLevel> </w:WordDocument> </xml><![endif]–> Ok, so this past Christmas, I got a Memorex MRX 800LU external blu ray burner for my laptop. I also got a 50 pack of Rosewill 4x BD-Rs (both on sale). This is my first experience with anything blu ray on the computer.

After about a month, I had burned maybe 10 video or data discs. All of these discs completed successfully and seemed to be free of any issues. The video discs all played fine on my standalone LG blu ray player. So, I don’t think it could be a problem with the burn or burn speed. And original ISO files that I kept for SOME of the video discs all play fine in a virtual drive on the computer without issue. So, I know it’s not a file, software, computer issue.

I first noticed a problem when I tried to duplicate one of the data backup discs I had made. It was EXTREMELY difficult to get the Memorex drive to read this disc. It took me a few tries to get it seated so that it could even recognize it and when it did, it took quite a while to copy it.

I then started to verify my other discs, all had the exact same issue. I also noticed that with video blu rays, playback was VERY jittery, inconsistent or stuttered (on the Memorex drive). My first thought was just a compatibility issue, that the drive just didn’t particularly care for the brand of discs.

So, I ordered an HL internal slim BD-ROM drive off Ebay. After all, if the LG player played them fine, one would figure an HL drive (Hitachi/LG) would read them well as well. Not the case. The HL drive did the EXACT same thing as the Memorex drive.

So, I figured it had to be the discs, after all, they are bargain discs. So, I ordered a package of 3 Memorex BD-RE (or is it RW?) discs that I found for cheap on Ebay. They actually burned, read and played well all around. Video playback was good (as is also the case with original blu ray commercial discs). So, at this point, I was blaming the issues on the Rosewill discs.

I was looking on Memorex’s website for compatibility and… " BD-R SL: CMC, SONY, MITSUBISHI, RITEK, TDK (HtL), TY (LtH)." Unless I am mistaken, Verbatim is made by Mitsubishi Chemical. So, I proceeded to order a spindle of Verbatim BD-Rs, of which I have always heard good things. Much to my chagrin, these Verbatim discs had the exact same issues as the Rosewills, on both the Memorex and HL drives (maybe even worse actually).

So, now, I’ve got all this money in all these different blu ray products, and I still can’t narrow down where the problem is. I am seeking advice before I do anything else.

One more thing to note, I just had a DVD-R data disc that I was trying to copy. Neither the Memorex nor the HL drive would read it. It was a little scratched up, but not bad. My brother’s newish TSST (Toshiba/Samsung) DVD drive on his desktop read it no problem though.

So, I’m kind of thinking it seems like a weak/old laser issue? I don’t know about the use the HL drive has seen, as it was used, but the Memorex drive is brand new, 12x, usb 3.0, 5.25" full size - NOT slim, whole 9 yards. One would figure it should do a pretty good job reading whatever you throw at it, especially discs that it wrote. I’ve always kind of been under the impression that slim/laptop drive lasers just simply are not as strong, so I’m not necessarily as perplexed by the HL’s struggles. Also, I checked, there are no available firmware updates for the drives.

Any thoughts? Does it just seem like a case of inferior drives? The only issue seems to be with BD-Rs. Are they just generally more difficult to read? I’m going to wait for advice, but I think my next step might be to return the Memorex drive (if I still can). Any insight or advice would be appreciated.
<!–[if gte mso 9]><xml> <w:LatentStyles DefLockedState=“false” LatentStyleCount=“156”> </w:LatentStyles> </xml><![endif]–><!–[if gte mso 10]> ******> / Style Definitions */ table.MsoNormalTable {mso-style-name:“Table Normal”; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:“Times New Roman”; mso-ansi-language:#0400; mso-fareast-language:#0400; mso-bidi-language:#0400;} </style> <![endif]–>

Just to rule out an issue with your laptop or OS, have you tried using the Memorex to read those BD-Rs hooked up to another machine?