Batch build (NOT BURN) DVD ISOs?

vbimport

#1

You know, I want to do for the ISO build process what IMGBurn does for the DVD burning process, make a list of DVD volume folders and click go and the software builds them all.

I saw on the IMGBurn forum that someone requested just that, but the author said ISO building involves way too many variables for that.

That may be true, but when we’re building DVD ISOs we can get away with almost no complexity (IMGTool Classic is proof of that - I’ve been using it exclusively for years now and not only are there practically no variables, what are there I don’t ever change). DVD ISOs are the vast majority of my ISO building/burning tasks.

So, is there an app out there that does this, that I haven’t seen yet? Is there maybe an app that can coax IMGTool Classic into doing this?

I wish the guy who runs IMGBurn would consider adding some simple queue functionality to the ISO build process (especially since he’s already written a queue function for ISO burning, and it has more variables than IMGTool Classic!).


#2

Write a batch file and just call ImgBurn multiple times passing it a different root folder and volume identifier.


#3

Write a batch file and just call ImgBurn multiple times passing it a different root folder and volume identifier.

I have no idea how to do that. Any advice or links?


#4

What am I doing wrong? All IMGBurn does is open in build mode and set the destination. Source is not set and it doesn’t start building.

“C:\path\ImgBurn.exe” /SRC “C:\path\VIDEO_TS” /DEST “C:\Image.ISO” /START


#5

And once I get it working right, do I just make an additional line for each image I want to build, or what?


#6

Okay, I got it working. It was some weird bug where I pasted in THE EXACT SAME text for the SRC path (yes, I triple-checked that it was the same) and then it worked. I was using 2.0.0.0 so maybe 2.2.0.0 has this fixed, if it was an IMGBurn bug which it probably wasn’t (even though the bug persisted through two different text editors).

I’ll post the syntax later for whatever poor slob reads this and needs the same info.


#7

Except I can’t figure out how to get the fucking thing to wait for one image to finish building before another instance starts up and begins building.


#8

If those lines are in a batch file (*.bat), it should wait for the ImgBurn.exe to finish anyway. (I just tested it from a bat file and it waited)

If it doesn’t, you might neet to use the ‘start’ program with the /wait argument.


#9

@John_Qyoo_Public

Please don’t use/post offensive language on these forums.


#10

Has anyone made an app to do in batch mode what IMGTool Classic does? Seems this would be trivial to code, could even set up an app to just call IMGTool Classic.


#11

Have you tried looking at the build mode of ImgBurn which can be controlled from the command line?


#12

I just added a guide to do this on my website, at the page http://www.ephestione.it/nfoimgburnbatchbackup.php


#13

The procedure and tool listed on the following page can be helpful in setting up the burn directories before burning:

P.S. This might be considered a somewhat advanced topic

@Ephestione: Welcome to CDFreaks! :slight_smile:


#14

Thank you :wink: I actually subscribed just to write this one post… I devised the method couple weeks ago, and was pondering if I should’ve invested the time to write a proper guide on my website (very lazy lately), but since I decided positively (sharing knowledge is good) I at least wanted to get a small payback in the form of website visits, thus the link in this topic :wink:
EDIT: btw the method linked in your post does look very promising, alas in my case it won’t be very useful, as I usually burn bunch of episodic avi content, and I wouldn’t like the files to have any order in the dvds different from the normal progressive order, even if that means wasting some space at the end of the disc.


#15

[QUOTE=Ephestione;2272643]I just added a guide to do this on my website, at the page […][/QUOTE]

Very strange that I cannot edit my previous post, is it because it’s old? I am sorry to up this prehistoric thread, but since I still get hits from here, I bumped to update the link as I migrated the website to wordpress and reworked the URLs, here is the guide now http://www.ephestione.it/how-to-use-imgburn-for-batch-buildcreateburn-iso-to-backup-to-dvd/ :slight_smile:

Mistery solved: I can in fact edit this post, but I can’t do the same with the previous ones… there must be some sort of “late edit protection” active :stuck_out_tongue: