Bad flash using 3530 and 3.23 Firmware, seems I'm not the only one

vbimport

#1

Hi,

I’ve tried to update the firm ware on my 3530A Drive from 3.01 to 3.23 however I seem to be having similar problems to this thread:

http://club.cdfreaks.com/f86/my-3530a-update-iodate-oem-v323-failed-help-196288/

To confirm, when I perforemed the flash, binflash said it was sucessfull and after restaring te computer my, the pc detected the drive and the operation light and eject buttons function as normal however if I put a disc in the drive just goes ‘tick tick tick’.

When I tried to dump the dodgy 3.23 using the dos version of binflash, all I got was this

C:
ecflash_windows>necflash -dump -v -s oldfirmware d:
Binflash - NEC version - (C) by Liggy and Herrie
Visit http://binflash.cdfreaks.com

Dumping firmware
// sptxSay.DeviceIoControl: x15 (21) The device is not ready.
// sptxSay x 0 0 60 E (ioctl status length senseLength)
// sptxSay.DeviceIoControl: x15 (21) The device is not ready.
// sptxSay x 0 0 0 E (ioctl status length senseLength)
Reading FLASH at 0x006000 in bank 0
// sptxSay.DeviceIoControl: x15 (21) The device is not ready.
// sptxSay x 0 0 1000 E (ioctl status length senseLength)
Error reading firmware from drive
Error while dumping firmware

Does anyone have any ideas on what I could do to rescue my drive? Any help would be greatly appreciated.


#2

Is the drive seen in BIOS and Device Manager, and has flash back to 3.01 firmware been tried? Try a different IDE cable to determine if bad cable.