Bad Flash from 1633 to 1673. any solution?

vbimport

#1

Hello aLL!!
I’ve made a big mistake i think, i’ve flashed my liteon 1633s with the new fw 1673s. the result is that the windows no more recognize it.
I’ve tried all mtkflash versions… but nothing dvdwriter always show me a led that turn off and on.
I’ve tried winmtkflash too and it says me after a while: fail to identify the flash type!!
At this point the led stop to blink but nothing else happens.
Could someone tell me a valid solution please?


#2

use flashfix to re-flash your drive


#3

Flashfix can re-flash only windows recognized devices.
ut mine is no more recognized!!
That’s the problem!


#4

hi there,

have a look here, i saved my liteon after a bad flash.
regards.

http://dhc014.rpc1.org/howto.htm


#5

hello,

i made the same mistake,
see here


#6

hello,

i answer to myself,
the solution was in the forum

i’ve found it in this thread

[quote=“C0deKing”]

Yes, it must be held during the power up reset. Note, this is only required for MTKFlash, not a normal Windows flash.
[/QUOTE]i have used mtkflash v1.83c

:bow: thank you C0deKing


#7

Really IT WORKS GREAT!!
THX CODEKING!!!
and thx to all others for the support. My 1633s is not working!!!
I’m so happy :slight_smile:


#8

hi i have a question can i flash my 1653s drive to 1673S?
thanks!!


#9

@ symbios24
no you cannot flash a 1653 to a 1673


#10

DVD Writer works yet great in reading/burnig DVD, but i have difficulties in reading cd, any solution for this problem?
I hear strange rumours when there is access to the cd’s
Bye


#11

If you do a search, you will find many posts about this problem. Check your powersupply (try another if you can) and try removing your drives driver and the IDE driver channel, followed by a reboot. If these don’t work then you might have a faulty drive :sad:.


#12

If you did not have the cd problems before you flashed your 1633 to 1673 (which does not work), you should restore a backup of your eeprom made before your crossflash attempt.


#13

@ala42
Interesting…do you know of this as a cure, or is it just a hunch?


#14

This is just a guess. If the drive did not have the cd problem before and CD reading was fine shorty before the wrong flash it is quite probable that the flash changed the behaviour. The only thing you can revert is the eeprom and also the firmware, just in case mtkflash did not work as it should. So verifying the firmware was also a good idea.


#15

Sounds like good advise to me :). Hope it works…