Backup with subtitles

I am familiar with backing up DVDs but have never backed up DVDs with subtitles. I am now enjoying more foreign films and want English subtitles but am unable to make it happen.

I have tried all of the backup options (Full Disc, Main movie, Customize). I have selected “English subpicture”. Even when I backup Full Disc, I never get subtitles.

I have tried several different DVDs with no luck. Once it is on the harddrive, the subtitle choice is always grayed out - when I play the DVD itself I can choose to see the subtitles.

I did go through the online information and did not see any different information than what I have already tried… and I have tried 3 different DVDs going through each backup choice on DVDFab Platinum.

I think I must be missing something obvious, anyone know what that might be?
thanks.
Duck

In DVDFab’s settings, do you have [B]Do not preselect any subpicture track[/B] or [B]Please select the following subpicture tracks [/B]selected?

[QUOTE=Dialysis1;2242453]In DVDFab’s settings, do you have [B]Do not preselect any subpicture track[/B] or [B]Please select the following subpicture tracks [/B]selected?[/QUOTE]

On the Subpicture panel in Common Settings, I have “Preselect the following subpicture tracks” … and have “Preselected Languages” set to English.

So now the ripped files that are on your HDD don’t have subtitles? Is that correct?
Remove all preselected tracks and at the bottom choose [B]Select all tracks[/B].
No matter what the settings are you should be able to select the subs you want.

[QUOTE=Dialysis1;2242467]So now the ripped files that are on your HDD don’t have subtitles? Is that correct?
Remove all preselected tracks and at the bottom choose [B]Select all tracks[/B].
No matter what the settings are you should be able to select the subs you want.[/QUOTE]

nope, wiped everything, removed all preselected, selected all tracks, selected Full Disc, and when done still no subtitles on playback

If the original disc played the subtitles automatically, then any backup you make with Full Disc should also. With Customize (unless you leave the menus), Main Movie or Merge, you will need to put checkboxes in the subpicture streams boxes and click to turn on the default arrow (for many DVDs) to make them play automatically. The default arrow is discussed on the tutorial pages for Main Movie and Customize: http://www.dvdfab.com/docs/index.php/Main/DVDToDVDMainMovie

I just tested this with the R1 version of [I]Manon of the Spring[/I], a French film with non-forced English subtitles. The subtitles worked perfectly with the proper settings.

I rechecked to ensure that there were arrows in front of my choices. I have attached a jpg to show how it looks. In addition, you will note that the preview window clearly shows subtitle on the movie as the preview is playing.

(arrrgh)
Duck


Dumb question #1097.
Have you tried the remote to see if the subtitles are turned on?

[QUOTE=Benhad;2242562]Dumb question #1097.
Have you tried the remote to see if the subtitles are turned on?[/QUOTE]

no such thing as dumb question, but I am glad you have the notion that it will be something silly (and likely embarrassing) in the end…

[ol]
[li]I used PowerDVD to view the DVD and confirmed that the DVD had subtitles and that I could view them.
[/li][li]I then backed up my DVD using DVDFab.
[/li][li]I used PowerDVD to re-view the now backed-up files (on G: as shown in the jpeg).
[/li][li]I also used VideoLan and MPC.
[/li][/ol]
No subtitles and the menu pulldowns are grayed out… suggesting no subtitles available.

[quote=FDuck;2242544]I rechecked to ensure that there were arrows in front of my choices. I have attached a jpg to show how it looks. In addition, you will note that the preview window clearly shows subtitle on the movie as the preview is playing.

(arrrgh)
Duck[/quote]I understand your frustration. Try this: open DVDFab with no disc in your drive. Go to Common Settings->General->Preview and UNcheck both boxes. Click OK, then close and restart DVDFab with the same disc inserted and the same settings. Do not open the Preview window manually. Rip the first two or three chapters of the disc to a folder and see if the subtitles show up now.

The only dumb question is one that is asked twice.

[QUOTE=signals;2242578]I understand your frustration. Try this: open DVDFab with no disc in your drive. Go to Common Settings->General->Preview and UNcheck both boxes. Click OK, then close and restart DVDFab with the same disc inserted and the same settings. Do not open the Preview window manually. Rip the first two or three chapters of the disc to a folder and see if the subtitles show up now.

The only dumb question is one that is asked twice.[/QUOTE]

I tried this also with no success.

Sorry. I can’t duplicate the problem you are having. I have several other foreign films I will try to see if they work. There was a subtitle problem related to Preview in an earlier version of DVDFab. I noticed that the right click option in Preview did not recognize any of the available subpicture streams, don’t know if it’s related.

[B]Current status[/B]: I get subtitles using DVDFab (sort of). I used VoSub Rip (the Ripper wizard). Using VoSub Rip, I load the IFO and rip/demux both the idx and sub files. To play back, I select the IFO and then select the idx file (not the sub) to get subtitles.

I now clearly know that the files on my hard drive contain the appropriate files necessary for seeing subtitles but they do not show up when I play the movie from my hard drive; they are just not available to the software (the options for subtitles are grayed-out unless I have .idx and .sub on my hard drive).

Knowing this, is there a next step for me with DVDFab so that I do not have to do all of the post-processing? I would really like to have the subtitles integrated right into the movie (not a separate file).

The extraction should not be necessary, but is a workaround. I would also suggest you download and install the free and excellent DVDSubEdit. It will allow you to read and manipulate the subpicture streams (including making them forced) within the VOB files without having to demux and remux them. It would interesting to see if it finds the subs when reading the files that will not display them. Here is a link: http://download.videohelp.com/DVDSubEdit/