Backing up my ND-2510A FW?

vbimport

#1

Hi all,

Sorry I’m new, but I have read a bunch of the posts and tried it myself :o. I’m trying to backup my FW for my ND-2510A because I’m looking into trying to apply the 1.07v2b5 FW for my drive.

I try the command (in WinXP Safe mode command prompt):
NEC2X00A.EXE -pri -mas -old origfw.bin

and I get no fw showing up in my directory. I don’t own a floppy drive, and I’ve tried to make a boot CD with little success, so I’m wondering if I’m using the right utility to extract my original fw? I want to make sure I can back up the existing fw before I apply the 1.07v2b5 FW, in case there are any problems and I want to roll-back.

Can anyone point out to me what I’m doing wrong or if I’m barking up the wrong tree?

Thanks :confused:


#2

first of all go to bios and make sure nd2510a is actually in ur primary as normally hard drive is primary ide.
my xp has following config.
now my configuration is like follows:
IDE Primary ------------ hard drive 80gb
IDE Secondary 0 ------ Nec DVDrw 2510a
IDE Secondary 1 ------ Compaq DVD-rom
just double check it
someone else may be able to help u with issue of not having floppy drive

also you can download the firmware in this link posted by dvdboost
http://tdb.rpc1.org/firmware/2510_215.ZIP

that’s the fw version 2.15 that came installed in my nd-2510a drive.
hope this helps ur concern for backing up fw.
:slight_smile:


#3

Thanks for the FW link… I’m going to give it a shot myself again when I get home today. I’m going to be anal and try to back it up anyways. The NEC2X00A.EXE util doesn’t provide any errors when it’s unsucessful. It would be useful for it to have an auto-probe feature so it can detect where stuff is located on your computer.


#4

I agree with Yogi; your command probably needs to be -sec -mas, bc optical drives usually on sec bc primary is primary…unless of course you installed it in primary channel as a slave?..who installed your drive? you or they would know Just verify on Device Manager also works.

also, someone had your issue of no floppy, and somewhere on here they gave him steps to do up a boot disk…sorry i don’t have that link…but thing is, someone also advised him to invest the 25 $ and get a floppy put in…makes life easier on stuff like this: that way, your boot disk lets you flash from true DOS, which is “simpler”. window flashing works also; just that DOS flasing is more “express” and o they say safer/less can go wrong.

and, when you flash, they recommend here to put your fw.bin file in a folder in your c: drive, along with the nec2x00a.exe file. There’s a stepbystep thread we can find you, that he shows to put fw in like say, a “c:\2510” folder you set up. you then go to that directory in DOS and type your -out first, then your -flash command, and you can tell when it’s doing it; shows progress.

Last, in Dos, for me the fw.bin file name was too long, so instead of showing me I had the file nec2k5107v2b4d.bin, it showed it as nec1.07~1.bin. So, what I’m saying is, the file name may be truly one thing per windows, but in DOS it will see it as something like the second file name. For me it failed firsttime/said it could not find, but then i put in what DOS showd it as, and it did it! so, before you type the flash command, go, IN DOS, to the file’s directory, hit DIR /p, and write down the way the file shows in DOS, so it can find it and flash it.

Hope that made sense; just make sure you see the step process before you do it. Come back if more questions…we can try to find you that thread with chrome307’s instructions…search by his name: chrome307.
cya
ps. hey, here’s the thread
http://club.cdfreaks.com/showthread.php?t=93863 for “guide to backing up your firmware”…and also flashing it in essence is there: is what I used to learn and do it :smiley:


#5

ok i got it all working :slight_smile: I managed to scrounge up a floppy drive, install it, and get the FW backed up on the floppy itself. However, won’t be able to use the C: thing drive because my drive is NTFS. I tried the nec2k5107v2b4d.bin firmware, and I tell you, it didn’t really work well for my drive. I would get read errors and stuff near the end of disks when I used DVDShrink. It could have been that the media I was reading was burned on the drive with the original firmware (just trying a backup of a backup to see the performance of the drive). I flashed it back to the original fw and things seem to be fine again. I won’t risk any disks until Herrie gets the 2510a fw hacked properly with the appropriate removals :slight_smile:

Oh and I installed my own DVD burner. My main drives are on my secondary controller because I used to have a junky 20 GB as my main drive on the primary controller. At one point I upgraded to a new 60 GB drive and removed the 20 GB clunker. My CD drive was on the primary controller as a slave, but since I took out the 20 GB it was the master. When I put my 2510A in, it just replaced my old burner. To sum it all up… I was too lazy to swap the IDE cable :smiley:


#6

glad it’s working