AW G170A Audio playback problems

vbimport

#1

Hi,

I have the Sony AW G170A drive installed in a brand-new computer (Core2Duo, Abit AB9, 2GB RAM) and it burns DVDs, read data discs etc without any problems. However when I put an audio CD in the drive and play it through Windows Media player, the playback is full of pops and clicks.

If I rip the CD to my hard drive (using the same AW G170A drive) it plays perfectly. I’ve tried a range of audio CDs and they all have this problem.

Audio on DVDs has the same problem - it’s impossible to listen to a DVD on this player - there’s a buzz on all the sound which makes it robotic and distorted. I don’t know what to do - data-wise the drive is faultless, but audio playback is impossible. Could I have anything set up wrongly on the drive itself? It’s the Master (and only) IDE device.

One interesting thing… I just tried playing back a MP3 file at the same time as ripping another one from the CD, and got some of the same clicks that I’d get listening directly from the CD drive (but not as many). Cancel the ripping, and the clicks disappear.

I have the latest drivers for the Realtek HD onboard sound. How can I cure this problem? I don’t want to rip every CD or DVD onto my hard drive!