AVStoDVD Menu Creation Errors

vbimport

#1

I used AVStoDVD to burn two avi files onto a disc and ran into some error messages when trying to use both Menu Wizard and Menu Edit. The errors I got were:
Error: 383 - text property is read only
Error 340 - control array element 2 doesn’t exist

Any way to get AVStoDVD to create menus for multiple AVIs? The disc looks and sounds great but I’d like to add a menu.

This was my first time using the program.

Thanks for any help.

Ellen


#2

I’ve used this program quite a lot, but haven’t seen either of these error messages. I have no problems making menus for multiple input of video files, so what you are trying to do should certainly be possible.

The errors you are seeing are Visual Basic errors, but beyond that I haven’t a clue as to what is going on. Something corrupted? You can try uninstalling, then reinstalling the program.

And you can talk to the author directly with a bug report in this thread over at videohelp.com: http://forum.videohelp.com/threads/277852-AVStoDVD-Support-Thread/page21 He goes by the name MrC.
He will want to see the log file which is generated at the end of the encoding process and is in the same folder that your output goes.

By the way, do you have any special characters in the title? The authoring program that is used, called Muxman, doesn’t seem to like anything like [ or " or other non-standard characters in the titles.


#3

I did a conversion with AVStoDVD yesterday on a couple of .vob files .
I left the standard .vob names VTS_01_1.VOB .etc . There were no problems with these so I think the underscore is OK.
Unfortunately I didn’t create a menu since I usually use another menu program.

The only menu template I have right now in AVStoDVD is menu in black .

I will give it a try on a couple of .avi files & see if I get a problem.
Of course .avis’ can vary so much .


#4

I use AVStoDVD as well, that is my go-to-avi to DVD proggie…When it fails, and it does fail occasionally(they all do) I go to my trusty ConvertxtoDVD…Frankly speaking, it hardly ever fails…Granted the quality is better with AVStoDVD, which is why i go to it first, unless I’m in a hurry…
jm2cents, again…


#5

I was able to create a Menu where the text contained both " and ) .
The " text property is read only " could mean you are trying to use a “read only” font .
Check to see if your font files are "Read only " .


#6

Thanks for all the replies.

I tried a few things but nothing worked so I’ll contact the author (thanks for the link).

Here’s what I tried:
The AVIs had parens and dots. I renamed them to alpha only.
I downloaded and ran vbrun60sp6.exe.
I added mscomctl.ocx to the program’s lib file and registered it (it had been in system32)
Still got error messages and no menu.

One error, 53 - file not found error - advised that “menupage1.bmp” was not in the temp files path. This file is also not in the Menu folder in my Program Files directory. Nor is it in AVStoDVD_241_NoInstall.7z". Is it created during the menu creation process or was it not installed?

What menu creation program do you use, t0nee1, and how do you use it with avstodvd?

Thanks again for all the help.

Ellen


#7

I recommend an Uninstall of AVStoDVD , a reboot & then install the latest version fresh.
If you are trying to use the “No install” version that may be the problem.

I do no menu with AVStoDVD usually.
I use TitleWriter for most menus.With it I can use a small black .jpg for the thumbnails
A black background . The text for the selection. So what I get is a small size menu.

I think if you get the correct templates for AVStoDVD you could even create a motion menu.

DVDStyler can also create menus both motion & still but it has a learning curve .
I’m not going to recommend it unless you want to study quiite a bit.


#8

Mr. C told me to delete this registry key and it worked:
HKEY_CURRENT_USER\Software\AVStoDVD

He said that the program would restore it.

Thanks again for everyone’s help.

Ellen


#9

Good to hear you have a working solution ellentk. And this sort of thread educates us as well, so we can help solve this problem if anyone else comes in with a similar error.


#10

Of course Uninstalling then reinstalling as Kerry suggested in post #2 would have removed the registry key . At least it should have.
Good to see the author Mr. C replies quickly to problems.