AVI file wont play/open (tried maaaaany solutions)

Alright so, I downloaded a season of the tv. series OZ some files play and some don’t. At first I tried downloading VLC player and some files that werent playing before worked but STILL some wouldnt. So, I tried downloading ffdshow and they wont work with that either. Then I downloaded gspot and opened a file that wouldnt play, gspot said Filetype: unknown Mimetype: unknown.

I dont Fu*king UNDERSTAND why my files wont play!!! grrrrr But I am a newbie to this so its probably some stupid simple reason why the files wont work. (sorry if this message makes me seem like a jackass, im just very frustrated)

Can anyone help?

Downloading other people’s anonymous encodings always carried the risk that some of them are bad at source. If Gspot and VLC won’t work with them then something must be seriously wrong.

I suggest you buy the DVDs, seeing as this series is for sale at Amazon and you probably need to read the forum rules again before asking for help with copyright material.

Thread closed.