>avi file (movie) need to separate audio if possible

vbimport

#1

Hi guys :slight_smile:

I know that if a file has 2 audio tracks that this can be done fairly easy (i think) but my viewing programs are only showing 1 audio selection, so I’m assuming there is only one track.

The file is of a movie, with the original English dialog in the background. What someone has done is placed what sounds like an amateur dub in another language “on top” of the English…to the point that it’s just not realistic to hear or understand the English.

So I’m trying to find a way to see if I can separate the two or reduce the one to the point where the English is much louder and can be understood.

Removing the foreign dub would be the most preferable :wink:

Any suggestions of the software and process needed would be as always “greatly” appreciated!

Regards

MC :cool:


#2

To remove an audio stream from an AVI containing two audio tracks you can use VirtualDubMod. The procedure is the following.

Go to menu “Stream” and select “Stream list”

In the window then select the audio stream you want remove, and press the “disable” button.

Then Right click on the audio stream you want retain and select “Direct stream copy”.

Press OK to close the window, and go to the menu Video. Select “Direct stream copy”.

Finally, go to menu File --> “Save as…” or press the “F7” button, and save the new file with a single audio stream in any folder :slight_smile:

If the AVI has only a single audio stream, however, there is no way to remove the “added” language for what I know :frowning:


#3

Thank you Geno I’ll give that a try and see what happens :slight_smile:

But if it was 2 tracks wouldn’t only 1 play at a time? Maybe I confused with how it was encoded. I’m not sure why “anyone” would make a dub and place it OVER the original language so that both are mixed and able to be heard?

Frustrating to have the movie I want and have the English there, but not be able to isolate it.

I’ll update as I dig into it after work :wink:

TY again!

MC


#4

You’re welcome :slight_smile:

Usually when an AVI movie contains two audio tracks is to have a movie with more than one language, but these tracks are never played at the same time. With the playing software (I use VLC for example) usually it’s possible to select the audio track you want to play.

I suspect that your AVI has only a single track :frowning:

Placing a voice over another is something I saw frequently for example when a journalist is interviewing a person speaking a different language, and to help people not able to understand the foreign language usually the fastest way is to lower the original language volume and put a translated voice over the original one. If this is what was done in your AVI movie, I think that there is no way to remove the added voice.

Maybe extracting the audio track and saving it as a wav file and then using an advanced audio editor to remove some frequencies or applying some filters can improve the audio quality, but I have no idea how to use an audio editor to do this :frowning:


#5

Ty again Geno :slight_smile:

I was able to find this on another forum from '06:


This might work too, I have Audacity so I should be able to use that to take a look.

If that turns out to be the case (the 1 track) if I’m able to create a file with primarily the English audio, how would I re-combine the new saved track back with the original movie? And what would you suggest as to the which encoding I should save it as?

Would VirtualDubMod help me with this part?

I use to mess with this kind of stuff when I was working with vcd’s but that’s been about 6 or more years ago and I’m afraid I’ve forgotten most of what I’d earlier pieced together.

If I can just get the .avi with the right audio, I have software that I can then use to convert to dvd…

So I’m not needing the full process form .avi to dvd, just had to manipulate the .avi file on it’s own.

Hopefully that will be easier :wink:


#6

Yes, VirtualDubMod can also add any audio track to an AVI.

I suggest to do as follow (actually I don’t know if there is a better way).

First of all, save a copy of the original file somewhere in your HDD (it’s safer ;))

Then open the AVI go to menu Video --> Direct stream copy

Go to menu Stream --> Streamlist. Select the audio stream, and then press the “Disable button”. In this way you have a video only file with no audio.

Press F7 (or go to menu “File” --> “Save as” and save the file (as I said previously this is a video only movie) on a folder (possibly a different folder to avoid confusion and to be sure to not loose the original file.

Then open again the original video, the one with the audio you want to modify, and go to menu Stream --> stream list and select the audio track. This time press the “Save WAV” button. This save the audio only on a folder in your HDD.

After you modified the WAV file with the audio editor, to insert it in the avi run virtualdubmod and load the video only file you saved previously (the one with no audio).

Then go again on the menu “Streams” --> Stream list. Press the “Add” button and search for the audio file you modified with the audio editor.

Finally, select again the option “Direct stream copy” both for audio and video, and save the file with a different name. If you worked correctly with the audio editor, there should be no asynchrony between audio and video strams :slight_smile:


#7

Wow Thank you Geno!

I’m sorry for taking so much of your time (and effort) but I’m very appreciative and thankful :slight_smile:

That does look to be my best bet, if it IS just one track like I think we’re both thinking it is :wink:

I’ll follow that step by step and let you know how it goes!

Best Regards

MC :cool:


#8

[QUOTE=MrCairo;2063351]Wow Thank you Geno!

I’m sorry for taking so much of your time (and effort) but I’m very appreciative and thankful :slight_smile:

That does look to be my best bet, [B]if it IS just one track[/B] like I think we’re both thinking it is :wink:

I’ll follow that step by step and let you know how it goes!

Best Regards

MC :cool:[/QUOTE]

If it is then you should really re-think about the source of that file/video…


#9

[QUOTE=chef;2063480]If it is then you should really re-think about the source of that file/video…[/QUOTE]

well I checked the file with my main 2 virus programs and came up empty…it’s been on my comp for a few weeks now with no problem thus far.

But I hear what you’re saying :wink:

If I could buy this as a dvd I certainly would, I’ve checked all over the web and other than a short lived Japan release (which is now out of print) this was the only version I could find with an original English track, there is a German one (which i have as well) but no English.

If either film had sub-titles I’d be fine, alas neither do…I’m just trying to get a version I can watch and understand and hopefully enjoy lol

never had this problem before, normally I can find a legit copy of whatever I have my eye on :wink:

This is new, but I’m learning heh

TY for your words of caution!

MC


#10

Well some interesting results so far.

I was able to use VirtualDubMod to strip and create a copy of the film with no audio, I also saved the original audio as a .wav file

The audio file is 267mb, but here is where is gets a bit strange. I can load the file in Audacity but it only shows the the length is about 4.6 seconds long. When I play it through Audacity it goes pretty fast and sounds like listening to a cassette being FF while in Play mode, like “searching” for the next song…if you know what that sounds like lol :wink: Basically audio at high speed.

Ok, so then I try opening it with Nero Showtime and it works and plays perfectly.

So then I try to load it using Nero’s Wave Editor and it says an Error occurred reading the file???

So I have the audio file separated but I can’t seem to find a program that will allow me to do any kind of editing.

btw, VirtualDubMod says the the original audio track is an AC3 format, could this be the problem?

I’m not sure why Nero Showtime will play the file but the Wave Editor won’t.

Or why the file seems “compressed” when loaded on Audacity.

So there’s the situation thus far :wink:

As always any suggestions or advice is very welcome and appreciated!

Regards

MC


#11

You might try the free, trial version of Goldwave with this audio file. It can handle some formats that Audacity cannot.


#12

Oh, forgot to mention this… Adobe Audition will let you import the audio directly from an avi, mpeg or wmv file. If there is something odd going on in your conversion from ac3 to .wav in VirtualdubMod, this may be a way around that. Adobe has a trial available, but I don’t know for certain if it is fully functional. You’d have to check it out.

Been a while since I last had access to Audition…I think the version I was using was 1.5 and they’re up to 3.0 now.


#13

Thanks Kerry I’ll give those a look :slight_smile:


#14

Well A quick and sad update…

I can’t get anything to work. I can extract the audio using Virtualdub, but then NO audio edit program I can find can open it successfully…I’m thinking there’s a compression issue. Audacity can open it but it’s a 1 1/2 hr file that shows up as only 4.5 seconds…yet Nero Showtime will play it correctly.

I’m at a loss.

I tried the Adobe and Goldwave with no success.

If anyone would like to take on the “challenge” please let me know and I’ll host the file and send you the ip address. It’s completely clean, ran various programs with nothing detected and had it on my system for 3 weeks now.

Great US indi scifi/horror show that’s unfortunately out of print with a very short Japanese release back in dec’07

This is the only version I can find from every source I know of. And I know quite a few heh, barring someone selling a copy on ebay or someone uploading the original version to a bit torrent site, this is all that’s there.

Sad because it does look to be an interesting show, if your into b movies like I am :slight_smile:

Thank you very much for ALL the suggestions. As far as I’m aware I’m not making any mistakes here, but I’m certainly no expert in such things.

Let me know if you’d like a stab at the file and I’ll get in touch with you.

Regards

MC :cool:


#15

Sending you a pm MrCairo…by the way, loved your performance in The Maltese Falcon :slight_smile:


#16

Usually when VDM demuxs the audio, even though it says it its wav, it is still compressed. You are most likely still dealing with an AC3 file named wav. Just rename the file to .AC3 and try converting it wav. (use HeadAC3he for this)


#17

[QUOTE=Kerry56;2068717]Sending you a pm MrCairo…by the way, loved your performance in The Maltese Falcon :)[/QUOTE]

Thanks, it’s alway good to have “friends” :wink:

Got your pm TY, having a bit of an issue but will keep you posted :slight_smile:

On a side note: I heard the Song “Friends of MrCairo” long before I saw the film lol

But yea…I’ve always loved the name heh :wink:


Thank you Daemonicus, I’ll give that a go as well!

Regards

MC:cool:


#18

[quote=MrCairo;2063228]Hi guys :slight_smile:

I know that if a file has 2 audio tracks that this can be done fairly easy (i think) but my viewing programs are only showing 1 audio selection, so I’m assuming there is only one track.

The file is of a movie, with the original English dialog in the background. What someone has done is placed what sounds like an amateur dub in another language “on top” of the English…to the point that it’s just not realistic to hear or understand the English.

So I’m trying to find a way to see if I can separate the two or reduce the one to the point where the English is much louder and can be understood.

Removing the foreign dub would be the most preferable :wink:

Any suggestions of the software and process needed would be as always “greatly” appreciated!

Regards

MC :cool:[/quote]

Did you ever figure out how to get rid of the dubbing? I’m having the same problem.The avi files has Polish dubbed over the English.I’m trying to figure out how to get rid of it using an audio editor. But so far no luck.


#19

I´m working on a similar problem…and had to split the audio off at the end

Home video in NTSC…want it in PAL
Problem is it is 16:9

In order to keep the right screen format the only way that has worked (and I´ve tried a heap of methods) was to :

  1. use Nero to recode it to PAL…which totally screws the screen format despite checking the option 16:9…but at least gives you PAL.

  2. Convert again with Super. Simply added the screwed-up PAL , and selected output as 16:9 and bingo. video is PAL and looks fine.

PROBLEM: now the audio sound horrible!

  1. With VirtualDubMod…added the VOB file, and disabled the audio ok (intending to add a clean audio from the original video)…BUT, guess what, the screen format is screwed up again…16:9 is squashed into 4:3

#20

[QUOTE=jxsilicon9;2070627]Did you ever figure out how to get rid of the dubbing? I’m having the same problem.The avi files has Polish dubbed over the English.I’m trying to figure out how to get rid of it using an audio editor. But so far no luck.[/QUOTE]

No way, because its not dubbed but made else by pirates.