Autoplay works only on 2nd attempts; CD/DVD burning doesn't work either

I bought my new IBM Lenovo Thinkpad T60 in December 2006. It came with a Matshita DVD-RAM UJ-842. I am running Win XP SP2.

During the 1st month I owned the laptop, Autoplay and all burning functions worked without issue.

After about a month, I started getting this 2 weird issues:

  1. After I would put an CD or DVD in the drive, autoplay would not initiate and if you try to explore the contents, nothing comes up. However, after you physically eject the drive, and reinsert, autoplay and explorer show up, and work properly.

  2. Also, CD/DVD burning functions using either Windows XP or Nero would not work.

I tried running various IBM Thinkpad System Updates throughout the year and always kept up to date with Windows Updates. Still no luck. I check Device Manager and there are no exclamation marks.

This is my DISCInfo:
DISCINFO VERSION : 1.6.1.6
VENDOR : MATSHITA
MODEL : DVD-RAM UJ-842
REVISION : RB01
VENDOR SPECIFIC : 512210KME2110260881
LOADING MECHANISM : Tray
NUMBER VOL. LEVELS : 256
BUFFER SIZE : 2048KB
INTERFACE : ATAPI
RPC2 SCHEME : YES
STATUS : Set
USER CHANGES : 4
VENDOR CHANGES : 4
CURRENT REGION : 1
ANALOG AUDIO PLAY : YES
COMPOSITE OUTPUT : YES
DIGITAL PORT-PORT1 : NO
DIGITAL PORT-PORT2 : NO
READ UPC CODE : YES
MULTISESSION READ : YES
MODE 2 FORM 1 : YES
MODE 2 FORM 2 : YES
READ ISRC CODE : YES
READ BAR CODE : YES
BUFFER UNDER-RUN : YES
MT. RAINIER : NO
CAN READ CDR : YES
CAN READ CDRW : YES
CAN READ CDRM2 : YES
CAN WRITE CDR : YES
CAN WRITE CDRW : YES
CAN TEST WRITE : YES
CAN READ DVD-ROM : YES
CAN READ DVD-R : YES
CAN READ DVD-RW : YES
CAN READ DVD-RAM : YES
CAN READ DVD+R : YES
CAN READ DVD+RW : YES
CAN WRITE DVD-R : YES
CAN WRITE DVD-RW : YES
CAN WRITE DVD-RAM : YES
CAN WRITE DVD+R : YES
CAN WRITE DVD+RW : YES
MAX CDR READ SPEED : 24
MAX CDR WRITE SPEED: 24

Any assistance would be appreciated!

Try to boot from a CD and DVD. If it wont work, your drive is probably failing.