AutoPlay Not Working

vbimport

#1

This is just frustrating me!!! Whenever I insert a CD or a DVD into either of my optical drives (Sony DDU1621 DVD-ROM or Sony DWU14A DVD+/-RW) the AutoPlay function does not work. I have gone under the Properties for each drive and editted all the AutoPlay options, but AutoPlay does does work. I have even changed Properties to “Prompt me each time to choose an action” but I don’t even get a prompt! WTFO!!! To play an audio CD, I have to open either Windows Media Player or Nero Media Player and select the drive to load the music. Same thing goes if I put in a DVD movie. These are not copied CDs or DVDs, actual store bought items. I have WinXP Home Edition SP2 installed. Any help would be appreciated.


#2

This Windows bug was suppose to be fixed with Windows XP Service Pack 2 (SP2). From your post, I see that you have more than one burner. I had the same problem after I attached a second burner to my system. The second burner would not prompt me to choose an action when I inserted a blank disk into the burner. I did the same thing you did. I went to the DVD-RW properties, selected the Autoplay tab, pulled down the Blank CD window and made sure that “Prompt me each time to choose an action” was selected. Nothing worked in the Blank CD menu.

The bug continued to plague my system until one day I flashed new firmware for the first drive. The problem with autoplay on the second drive was gone but now the first drive inherited the problem with autoplay. I disconnected the first drive from the system and only booted with the second drive. Autoplay worked again for that drive. I re-attached the first drive and started Windows. Autoplay works for the first drive again but doesn’t work for the second drive. Dajavu!


#3

Thanks for the information. The problem was fixed through a tweak in my Registry. I’ll use your information in the future. Fred


#4

Fred How Did You Tweak Your Registry? I Have The Same Problem. Mitch


#5

I have a similar problem. I have just installed an NEC 3520 and it will not autoplay. Windows explorer shows it as a CD drive where as my other drive (Pioneer DVD player) shows as a DVD drive and by right clicking on it gives me options for playing DVDs with WMP or AsusDVD. Does any one have any ideas?


#6

Thank you for all the replies guys! OK so I worked it out for myself. Windows XP was using a generic CD driver so I went to “update drivers” in device manager and it found the right one for it (Version 5.1.2535.0). I am happy now. :bow:


#7

microsoft has a small utility that will fix most autoplay problems.
http://www.microsoft.com/downloads/details.aspx?FamilyID=c680a7b6-e8fa-45c4-a171-1b389cfacdad&displaylang=en


#8

ugh.
I disable auto-run on all my drives.