Audio tracks burning is too long

vbimport

#1

I have first noticed this when I was copying an audio CD. I took me something like half an hour to do it. So I decided to go a little bit further and investigate this problem. I discovered that this bug was occuring as soon as you want to burn audio tracks, no matter the way (Burning an NRG image, mastering an audio CD, copying an audio CD).

The problem is the following: With data tracks, nothing special occurs. Everything is fine. For example, with an ISO compilation of 496 MB, I get the following burn times on an LG-GSA4163B (What I call real burn time is the total time without lead-in and lead-out phase times):

[ul]
[li]At 10x: Total time: 6:06 (Real burn time: 5:31)
[/li][li]At 16x: Total time: 3:53 (Real burn time: 3:28)
[/li][li]At 24x: Total time: 2:54 (Real burn time: 2:31)
[/li][/ul]

With an audio CD compilation made out of WAV files, with a total size of 486 MB (something similar), same burner, same media, I get the following burn times:

[ul]
[li]At 10x: Total time: 5:58 (Real burn time: 5:23)
[/li][li]At 16x: Total time: 5:55 (Real burn time: 5:29)
[/li][li]At 24x: Total time: 10:58 (Real burn time: 10:32)
[/li][/ul]

Now you can see where the problem is: Burning at 24x an audio CD takes double of time of burning the same CD at 10x :eek: (BtW, the 10x bench seems to be OK, regarding 1500 KB/s rate). I tested this with different burners and different medias, and the same problem occurs.

This bug is not related to NeroLINUX, as with USB external devices, everything works without any kind of problem. It is related to some kernel problem.
I tried several kernel versions. This bug seems to be unreproducable with kernels <= 2.6.4 (Tested with SuSE 9.1). Note that this bug also affects cdrecord and other Open Source projects related to CD burning.


#2

I agree with you that this bug does not seem to be a NeroLINUX problem, however are you sure it’s a “kernel problem”, or possibly a SuSE/mathf problem? :wink: I have been using 2.6 kernels for the last year and a half or so, mostly always with the latest and have never had this problem. I do not burn cd’s very often, but every 2 months or so I burn a couple for my mother-in-law, and they have always been fine. They origionate from either CD, wav, ogg or mp3 (or sometimes a combination), and none of the formats have ever given a problem. This was up until recently using cdrecord via gtoaster.

At the moment I’m running 2.6.11.10 (the latest stable) vanilla kernel (up until this evening 2.6.11), with Nero 2.0.0.1, and still have no problems at all copying from cd to cd, or image to cd, or files to cd. I cannot test with > 10x speed though, as 10x is the fastest medium I have here, and my hardware probably would not support much faster (800MHz).

I just did 2 burns of an official CD, being a short CD (165MB’s) to CD-RW from wav form like you did:

[ul]
[li]2:41 @ 10x
[/li][li]6:19 @ 4x
[/li][/ul]

Both CD’s were burned from WAV files created off the origional in this case. There is nothing wrong with them, and even more, they are detected correctly (cddb) from the burnt CD-RW. Data files have similiar ratios in terms of speed/time with no problems either.

I cannot reproduce the results you are getting (reversed speeds) either, which is strange, unless it only happens with > 10x burns (could you confirm by trying =< 10x)?

Just for the clarification ~ I helped Andreas Eckleder for about 2 years with beta-testing gnometoaster a few years ago. Although I’m not a programmer, I know gtoaster very well. Actually this is the reason I love NeroLINUX :wink: … and the fact that Nero provides it’s own burning software under the hood is a bonus. If I can provide any extra info / testing just let me know mathf. I love to help.

At the moment I’m using a Asus DRW-1604P with Gentoo, as my old HP burner only supports 2x RW burning.


#3

Humm… I have tested more than 1 distribution before claiming that this was a kernel problem :stuck_out_tongue: It happens on a 2.6.11 self-build kernel, 2.6.8.1 used by Mandrake 10.1, 2.6.8 used by SuSE 9.2 etc…etc… As I said, it is not significant in 10x, but only occurs when burning audio tracks at fast speeds.

Another interesting thing… we tested NeroLINUX under very old hardware (Celeron 400MHz with 64MB RAM) and it was also working quite nice, even if the whole system was a little bit slow :wink: We managed to burn a DVD+RW at 4x, and Data-CDs at 24x without buffer underruns


#4

The tests with your kernels, and “Mandrake 10.1, 2.6.8 used by SuSE 9.2 etc…etc…” were all done on the same hardware? Maybe it’s hardware-related… I don’t know. But yes, you might be right if this only occurs at high speeds.

About 1 month ago I burned a CD here at work on out SuSE 9.0 Professional at max-speed (24x approx iirc) which did corrupt (have only tried data though ~ also only with cdrecord… no X on the server). I presumed this to be shitty cd’s. Burning it again at a slightly lower speed (16x) seemed to have solved the problem. It uses 2.6.5-7.151-smp and a Plextor DVD-RW. You say it only happens with Audio though, so this is probably irrelevant.

Hehe, oh yes, it’s not a physical limit to my 800MHz and 10x, but more to my wallet (thus CD-R=hardware too :-)). A while ago I bought many blank CD’s with max 10x (as I had a CD-RW with max 4x anyway), so I don’t have any cd’s which are faster, nor really the money to go out and buy more blanks just to try proove a point, lol. With my DVD-RW I tend to burn all I need to RW’s :wink:

Again, if there is any info I can give, or anything I can do just let me know… I’ll try get my hands on a few faster-burning CD’s to test with though ~ I know they aren’t expensive (IE: this is not a desparate cry for cd-donations, hehehe).


#5

I also tested it with different devices :slight_smile:


#6

Seems that the problem has already been reported on the Linux kernel mailing-list. Have a look to http://lkml.org/lkml/2005/1/9/23.


#7

Ok, then it seems you have covered all aspects to this :wink:

I am still almost convinced I don’t have this problem (being that if it’s a kernel bug it should have popped up by now… that or nobody using > 2.6.4 ever coppies CD’s using high-speed hehe, I don’t know), and have managed to “borrow” 4 50x CD-R’s from work :wink:

I can test at home this evening on my gentoo machine, but would like some idea what to test before I start. I have an 800MHz (384MB RAM), so I guess 24x should not be a problem. Shall I try burning wav files (as audio of course) at the speeds you tried above? If I get results similiar to yours, the files (burnt) should be corrupt, right, or is this issue purely relating to speeds which it is burned at with no consequences to the data written?

If corrupted: Is this related to the bug reported on http://club.cdfreaks.com/showthread.php?t=137623 (they do state that cdrecord works fine though)?

If just speed: LOL, and then double-lol… I presumed this was corrupting the data ~ one big misunderstanding… my appologies.


#8

No it is only speed related… but sometimes, when copying on the same IDE channel you can have some cracky sounds when you playback the burned CD.
Apparently, the ide-cd driver just shuts down the DMA and switch back to PIO mode, which uses more CPU and dramatically reduces throughput.

This bug has already been reported (just have a look to the link above), but it seems that a fix has never been added. I just compiled a 2.6.11.10 from kernel.org (official one) and the problem is still inside.


#9

Ok, call me a fool then. I thought this was causing data corruption on the cd’s… missunderstanding. I missed the link you sent as you sent it while I was writing up my answer :wink:

Wierd, but that bug was reported on 9 Jan 2005… should have been fixed by now. Linux-2.6.11.2 was released shortly after that … so all the versions from then seem to have the same problem. Ok, I’ll test anyway and see what results I get.


#10

I just mailed Mr. Jens Axboe that is actually the maintainer of IDE subsytem and he told me that the patch will be included in 2.6.12 that should be out in a couple of days.
I’m looking forward to check the ChangeLog of the next kernel release :wink:


#11

Wow, that’s excellent news! I’ll test it as soon as it comes out too then to confirm…

I have just finished a bit of testing here. 646MB’s of WAV files to audio-CD.

[ul]
[li]@ 10x : 7:53
[/li][li]@ 16x : 5:10
[/li][li]@ 24x : 3:55
[/li][li]@ 32x : 3:49
[/li][/ul]

I am definitely not getting anything close to what you are getting (reversed times), however I do get your point, and you are right… there is something wrong here. Maybe it’s your choice of music G … probably country and western, hehehe. Although the order of values on my recorder is correct, the ratio doesn’t add up :wink: Oh, I must add that I did the tests using simulation (if it makes any difference) just for the record :stuck_out_tongue:


#12

I just downloaded and installed NeroLinux 2.0.0.1.

I have a Sony DRU-510 DVD burner, which is capable of burning at 4x. I have burned many DVDs at this speed from command line using “growisofs” as well as using K3B under KDE. I’m running Linux-2.6.11 on a Slackware 10.1 based system.

NeroLinux doesn’t seem to support burning DVDs at 4x. The maximum it will let me select manually is 2.4x. When I leave the setting at “Maximum” speed, it takes almost 30 minutes to burn a DVD. Using K3B the same operation (with the same content) takes less than 15 minutes. Is there another setting that I need to change somewhere?

Thanks in advance,

Rob.


#13

I thought I had this exact same thing (while testing based on your post) … My burner is also 4x, and NeroLINUX gave me aswell 2.4x ~~~ then it hit me… my DVD-RW media is limited to 2.4x!

I then put in a DVD-R (with 4x max) and NeroLINUX automatically changed the max speed to 4x … so all I can say is it’s working here fine.

Are you sure it’s not the media that is limiting your speed? I do have an Asus DRW-1604P though, but these silly mistakes can happen to all :wink:


#14

OK. Its fine with DVD-R media. Thanks for the tip.

However, all is not rosy. Now it writes the lead-in but dies after that saying:

“Power calibration failed”

The permissions on my devices are set correctly. They work properly with everything else.