Audio Sync Woes

Qutie strange. I have a Divx that the audio is off by just a bit when I run it in Dr. Divx but not when I use PowerDVD to view it. I have recently tried to convert and author it but I get the audio sync issue when I view the Video_TS file in PowerDVD, sam sync issue.

The process I am using is

  1. VirtualDubMod 1.5 to extract AC3 audio
  2. VirtualDubMod 1.5 to extract avi video
  3. AC3Fix to fix extracted AC3 audio
  4. Bitrate Calculator to calculate average bitrate (6008 Kbit/s)
  5. TMPGEnc to encode the video only (2 pass VBR)
  6. TMPGEnc DVD Author to create DVD files
  7. PowerDVD to view Video_TS folder (audio sync issues)
    8.) TMPGEnc DVD Author to write DVD (as soon as I get audio resolved)
    More specifics here

[b]Video Specs (YAAI)
AVI Information
Filename:
Filesize: 734277632 Bytes (700.26 MB)
Streams (i.e. Video, Audio): 2
Video Stream
Compression: divx - DivX
Avg. Bitrate: 767.55 kbit/s
Resolution: 512x288
Color Depth: 24 bits
Running Time: 5867.08 s (1h 37m 47s)
Framerate: 25.0000 fps
Microseconds Per Frame: 40000 ms
Frames: 146677
Keyframes: 4177 (Every 35)
Audio Stream
Wave Type: 8192 - AC3 Audio
Avg. Bitrate: 224.00 kbit/s
Sample Rate: 48000 Hz
Bit Depth: 0 Bits
Channels: 2
Audio Delay: 0.00 s

Could it be a codec issue that I am facing here? I am a little stumped why it would play fine in PowerDVD in its orginal Divx format but not in Dr. Divx. As well why does this issue pop up again once I have encoded and authored it?

Any ideas?
:confused:

I was thinking… Is there a tool out there that will let me view and sync M2v and AC3 files? That would be the easiest way to do it I guess. If I can straighten out the sync problems then I can just author it.

Thanks
:slight_smile: