Audio Sync Problems

Hello,
I am new here but, have been converting AVI to DVD for awhile now. I am sure you have all heard what I am going to explain before over and over again. But, I can’t seem to get the audio to sync in with DivX AVI’s.
I have searched and searched. I have tried all the guides and nothing seems to work. When I found this forum and read ChickenMan’s giudes about using Maestro I thought that I was on to something but, ran into a brick wall again.
I have tried the AVI2DVD program which I thought was going to work fine but then it would come up with it’s own errors like when it tried to save the CCE project it says “failed to save project file” and stopped right there. But, it was still in the CCE program so, I just right clicked the file and chose edit then encode and I thought that the AVI2DVD program was just going to continue until it got to the Pulldown part of the program saying that it could not find the Pulldown_Encoded_Video_NTSC.mpv file. So, I tried the AVI2DVD program again and this time when the program stopped at the failed to save project file spot I then named the file Pulldown_Encoded_Video_NTSC.mpv. When it finished encoding it said the same thing “Could not find Pulldown_Encoded_Video_NTSC.mpv”.
Well, back to the drawing board. I ran into one of the guides here and Chickenman had stated to refer to the DVD to DVDR guide on how to use Maestro. Well, I follwed the guide to the “t” but, when I try to import my audio file I get a “Media Detection Error” everytime. I tried saving a “Full Processing Mode” WAV file from VirtualDUB and the same error. I tried saving a “Direct Steam” WAV file from VirtualDUB and the same error. I tried saving a MP2 audio file with TMPEGEnc Plus and the same error. I tried to convert the WAV’s to AC3 using BeSweet and the same error. I tried converting the MP2 file to AC3 using BeSweet and the same error. I can’t seem to get this DivX AVI files audio to sync at all no matter what I do.

 Can someone please explain how to do this or what I am doing wrong.

Thank you in advance :slight_smile:

When you say,

I am new here but, have been converting AVI to DVD for awhile now

Did you mean DVD To AVI (DivX)?

If so the best way I have found is to make sure you encode your audio to mp3 with a bitrate of 192Kb/s. Before this I was using 128Kb/s and nearly always got sync problems.

Womble: By the sounds of it, it sounds like movienut is trying to convert his divx films to DVD using CCE and maestro.

Have you actually been able to use dvd2svcd to create your mpv file or not? It’s not clear in your question as you say you get errors trying to do so.

dvd2svcd will extract and convert the audio for you to an mp2 file, you can import that or use besweet to convert to an ac3 file.

Monaghan is correct. I am trying to convert my DivX AVI’s to DVD.
The AVI2DVD program does create the MPV and MPA files but when it comes to the part of the program to run Pulldown then I recieve another error stating that it can not find the file.
Well, I have tried to reconvert the audio file with HeadAC3he and when I start up Maestro and load the new WAV file it loads in but, when I try and load in the MPV file it says Media Detection Error.
Why can’t I load more than 1 file into Maestro? By, Chickenmans guides you should right-click or double-click on the window in the lower right hand corner and select your MPV file then wait for Maestro to load in the file then right-click or double-click again and load in your Audio file. Right? But, when I try to load in the second file (either Audio or MPV) I get a Media Detection Error.

What am I doing wrong or is there something wrong with Maestro?

CM’s guide is correct. You should just be able to import virually any number of files into there.

Why are you trying to import wavs? They’re huge and leave very little space for the movie.

If the divx has an ac3 file you can just demux it using VDub, eg. using VDub mod, open the avi, select streams -> stream list, select the stream and demux. You can also demux an mp3 audio files this way.

What format is the audio to start with?

Thanks for all the reply’s in trying to help me here. I appreciate it I really do. Well by what GSpot says it is a MP3 Audio file. So, I will try that. I also, had just learned something else. When I first import a file into Maestro, Maestro has to look the file over (I guess) and it loads in (I see a progress bar going next to the file I have imported). OK, here is my new problem. I loaded in the MPV file and Maestro checked the file out by loading it in. When I tried to load in the Audio file I got the Media Detection Error. So, I closed Maestro and started it again then I loaded in the Audio file and Maestro checked this file out and loaded it in. When I tried to load in the MPV file I got the Media Detection Error. So, I closed Maestro again and restarted it and was then able to load both files in this time (why I don’t know). So, I dragged my audio file up to the timeline under the audio part and it whet in fine. But, now when I drag my MPV file up to the timeline it tells me ‘The Video Asset length is greater than the maximum allowed’. Why? My aduio file is 1:47:10:00 in length and my video file is 1:47:17:13 in length. This should be a fine file length unless the size of the file is to great. I will see about re-encodeing the video file and see if I can get the size down (I just checked the video size and it is 4.8GB so that must be it). And I will try to redo the audio file per Monaghan’s instructions. I will post my results. Also, the only reason I keep on tring with Maestro is because ChickenMan has said that you will not have a sync problems with it. I have run into all kinds of sync problems with other software so, I am going to try this.

Thank again I really appreciate it.

Nut

Sounds like your installation of Maestro is screwed. Un-install and install again.

Your file size is not causing the problem either. Meastro doesnt really care what size the files are as its used to author dual layer DVD’s up to 8.5gig (for saving to tape!) But the 4.8gig size you have is due to using the WAV file. Convert the WAV to AC3 with BeSweet GUI or AC3 Machine (or if your player doesnt like them, use Sonic SoftEncode)

Also please bear in mind, DVD2SVCD does not handle AVI’s with faults very well, particularly audio problems. These need to be manually converted at times.

Thanks for the reply CM… When I was referring to the file size I was giving the actual size of the MPV file right from Windows Explorer the MPV file is - 4,719,651 and the WAV file is - 1,206,829. I will uninstall Maestro and reinstall it and see what happens. Thanks again for all your help everyone. I will post the results later…

Movie Nut…

Well, I uninstalled Maestro and then reinstalled it and I loaded both files (MPV and WAV) in the Media Assets. I dragged the MPV file up into the timeline and I get the same error ‘The Video Asset length is greater than the maximum allowed’. I can’t figure this out… :frowning: . I am going to try and re-encode the video file again and see what happens…

Movie Nut… :frowning:

movienut: your video is 4.7 gig which is probably too big on its own. Plus don’t use wav. Re-encode to an ac3 using besweet or ac3machine as CM advised.

That will drop your audio size down to about 3-400k. Re-encode your video by altering the disk sizes as per CM’s guide (I actually set these to be about 4100 as the outer edge of DVD-R’s are usually touchy. That would mean your final size is about 4400 leaving plenty for a menu etc.

If you really are having that many sync problems. I’d have a look to see if your files are corrupt.

Thanks Monaghan I am re-encoding as I type this. I just hate (as most of you do) re-encoding as it takes so long. My 1:47 movie takes about 5 hours with CCE and about 18 hours with TMPEGEnc. I kind of like CCE better because I use AVISynth to set all my parameters first and it seems to do a better job. I am going to have to agree with CM on this because if Maestro will do up to 8 1/2GB movie then it should do this 4.8 one. But, I will find out after it is done encoding. I have checked the file with DivFix to see if they are corrupt and it returns 0 errors. So, I don’t think it is a corrupt file. It is so weird that I don’t have any sync problems with my XviD AVI’s just the DivX AVI’s. I have about 20 DivX and have about 8 XviD’s and all the XviD’s have no sync problems. I would even like it if I could find a way to reconvert them from DivX over to XviD and hope that would solve all my problems… Thanks again for all your help all and I will post my results in about 3 more hours…

Movie Nut

Well after all this time I still can not get it to work. I loaded the newly created M2V file into Maestro and it told me that the frame rate wasn’t good. So, I used pulldown to get it to 29.970 and then I double-clicked the asset window and loaded in the m2v file (Man it took a long time for Maestro to load in the file under the status). After that I tried to load in the ac3 file and I got the same error message ‘Media Detection Error’ so I exited then restated Maestro and loaded in the ac3 file this time, then I attempted to load in the m2v file and the same error ‘Media Detection Error’. So I exited Maestro again and restarted then I was able to load in both the m2v and ac3 file but when I tried to drag the m2v file into the time line I get the same error ‘The Video Asset length is greater than the maximum allowed’. I don’t know what to do. I am lost and will try different programs. Thanks you you help everyone as this seems to be a lost cause…:frowning: :frowning: :frowning: :frowning: :frowning: :frowning: :frowning: :frowning: :confused: :confused: :confused: :a :a :a :a

Movie Nut

CM might I ask what version of Maestro you use? I use the 2.5.1 SP1 maybe that is the problem…???
Also, do you think it might be a codec problem? I install the Tsunami Filter pack and have been reading alot that others say not to use it. What is your take on this CM?

Movie Nut

I’m using their last issued version for the PC, ver 2.9 build 2915a

As for Codec packs, I hate them all. They are for lazy people only and tend to cause more problems as they solve. If you just select the codec you NEED and not on a nice-to-have basis, then they are okay. But if you just install them all, almost guarenteed to cause problems.

Thank You CM, … I no longer have the ‘Media Detection Error’, or the ‘The Video Asset length is greater than the maximum allowed’. Thank You for all your help… I will post a reply here after I finish compiling and burn to DVD and see if the audio is in sync. THANK YOU AGAIN CM!!!:bigsmile: :bigsmile: :bigsmile: :bigsmile: :bigsmile: :bigsmile: :bigsmile: :bigsmile: :bigsmile: :bigsmile:

Also, if this works I am going to redo my system (format and reinstall XP) and just install the codec’s I need this time… I should need the following:
Newest DivX codec
Newest XviD codec
Any others or suggestions can you please reply to this post CM…

Thank Again

Movie Nut

Well, back to the drawing board. I finally got Maestro to work via CM’s help but, now I can’t get any sound after Maestro finishes encoding. I have followed all of the suggestions that everyone has posted here but, I can’t seem to get the sound to work. I am going to search the forum for suggestions. The original sound from the AVI is an MP3 sound file.

Movie Nut

Sounds like you need some AC3 codec installed, I would suggest AC3Filter from http://ac3filter.sourceforge.net/

I assume you have converted your MP3 audio through to AC3 ? If not see my earier posts above.

CM I did not have the codec’s installed so I downloaded as per your instructions and installed the AC3Filter. After I installed it I rebooted my machine. I load AC3Machine and converted my MP3 file to AC3. I then loaded Maestro and loaded in the AC3 audio and video file. I did everything as per you tute and then compiled. I went to the directory where it compiled to and double-clicked one of the ifo files and still no sound. What am I doing wrong. Seems like I am going around in circles here. I did play the MP3 file in media player first before I converted to AC3 to make sure it worked and it played fine. Any suggestions?

Movie Nut

Also, if everything is installed properly shouldn’t I be able to click on the ‘Play AC3’ in AC3Machine and the ac3 file should play? Maybe I have to uninstall the Tsumani Filter pack and just install the codec I need only?

Originally posted by Movie Nut
Maybe I have to uninstall the Tsumani Filter pack and just install the codec I need only?

Sounds like a good idea to me.

Also, try converting the MP3 to WAV with BeSweet GUI, then use AC3Enc ( that comes with Scenarist) to convert the WAV to AC3, there is tute on how to use AC3Enc

Ok Cm I uninstalled the filter pack and just installed DivX 5.1 and 3.11a and Xvid and AC3Filter. I rebooted and now shouldn’t I be able to click the ‘Play AC3’ in AC3Machine and play the AC3 file? Because it doesn’t happen. Maybe something else I did wrong? Don’t Know?

Movie Nut