Audio Problem playing DVD-Rom

vbimport

#1

Hello, first, I’m new here, so if you need to ask me for more info, please do.

I have an Optiarc 7170A on a PC running Win XP Pro, 2 Gb ram and my problem is the audio is jumpy and the DVD seem to be running slower than normal. This DVD is set up in flash and / or QuickTime as a Photoshop training DVD.

I’ve check the following; VM cache increased to 4096, and is set to DMA mode on both primary and secondary IDE’s.

What should I look for next?

Where is a safe firmware update?

Rockwell18


#2

Set to which DMA mode?


#3

The transfer mode of the primary and secondary IDE devices are set to “DMA”. I saw that in another trouble shooting area.

Rockwell18


#4

The “Current Transfer Mode” for devices should show “Ultra DMA mode n” where n= 5 or 6 for an HDD and 2 or 4 for a burner.


#5

Exactly that is why I asked…


#6

OK, here’s what I have -
Primary IDE - Device 0 - “Current Transfer Mode” set to Ultra DMA Mode 5
Device 1 - “Current Transfer Mode” Not Applicable

Secondary IDE - Device 0 - “Current Transfer Mode” Not Applicable
Device 1 - “Current Transfer Mode” Not Applicable.

Now, these are the setting for the first of 3 each of the primary and secondary IDE’s listed.

Rockwell18


#7

So there is only a harddisk connected and running in UDMA5, nothing else.


#8

The setup I have is this:
Primary device 0 - C drive (hard drive)
Primary device 1 - D drive (hard drive)
Secondary device 0 - DVD-Ram (Optiarc)
Secondary device 1 - Plextor CD burner.

On my device manager in the drop down of the IDE controller, it lists 3 primary and 3 secondary devices. Do I need to change all of these to be Ultra DMA?

Rockwell18


#9

One other thing, if I need to change some of these, the drop downs don’t show that option. How do I change them?

Here’s the settings for most -

Device Type is set to "Auto Detection"
The “Transfer Mode” is set to "DMA if available"
Current Transfer Mode is set to “Not Applicable”

Rockwell18


#10

You should only have 1 Primary & 1 secondary controller.

I think it’s time to delete all the secondary controllers & reboot. If that then results in just 1 secondary check the DMA status.

I believe that deleting the primary controllers might affect booting but I’m not sure. However, I think that’s probbaly what you’ve got to do.