Audio encoding by BeSweet

vbimport

#1

Hi. I post this here because you made me discover BeSweet.
I found this strange feature. I choose, in BeSweet+BeSweet GUI, the profile ‘MP2 for SVCD’.
This profile, by what I see, ahould set the bitrate at 192 kbps.
Instead, since I’ve obsarved that a MP2 created for a 1h 53’ movie was

  • 106.5 MB if created by BeSweet
  • 189.9 MB if de-multiplexed by TMPGenc from the final mpeg

I begun using also HeadAC3he. What i found is that, by opening the 106.5 MB audio file, HeadAC3he shows:

  • stream info: MP3 48 kHz 2ch joint stereo 128 kbps
    instead, by opening the 189.9 MB file, I see:
  • stream info: MP2 44.1 kHz 2ch joint stereo 224 kbps
    and this is correct, since 106.5/189.9 = 128/224.

Therefore, it seems that BeSweet doesn’t create a ‘true’ MP2 file as it is shown.

What I cannot understand is that if I add the MP2 stream to a ‘mute AVI’ with VirtualDubMod, the resulting AVI cannot be correctly re-transformed into a MPG if it is the ‘correct’ MP2 (224 kbps), but if I add the ‘bad’ MP2 stream created by BeSweet the resulting AVI can be correctly re-transformed t mpg by TMPGenc.

Any comment? I will keep the ‘AVI mute video’ and the ‘MP2 sound’ file separated, just to be sure, but that’s is strange…I would’t like to lose quality in the audio stream…


#2

I use the BeSweet “Suite” myself…

I’m guessing here that the reason the BeSweet stream works is because 48kHz (and multiples thereof) is DVD sound. 44.1 is CD sound.


#3

Hi,

Actually there is No such thing as a BAD mp2. What has happened is that the configuration for the setting you have chosen is 128 kbps for the audio instead of 224 kbps. Hence the size diff. Cause 128Kilobits/sec instead of 224 Kilobits/sec. So if you know a little bit of programming, you could edit the .ini file in the Besweet folder and make a custom setting for yourself which would then be displayed in BeSweet Gui with all the settings You specifically want in the audio output. OR in the alternat you could check out DSPGuru’s setting which are quite good. But I generally use my own custom settings. Also Trak101 was correct, The s-called “bad” avi is NOT “bad” but has the wrong frequency(std DVD audio is always 48khz whereas Std VCd freq is always 44.1k). So when you want to make a DVd output,ergo everything vomits.

Hope this helps.


#4

Yes. I downloaded the BeSweet upgrade editing some (silly) default options. Now I can encode at 224 kbps (instead of 128 kbps - v1.4 - or 192 kbps - v1.5b29) and, manually editing the SSRC options, I forced the 48 --> 44.1 kHz converstion (I had to do it, even if I already checked the ‘downconvert sample rate’ box before!).